summaryrefslogtreecommitdiffstats
path: root/meta-netboot
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2017-06-20 17:07:53 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-23 11:16:47 +0000
commit21169829e77c8ec93a3a3287e478eea9a2ce2129 (patch)
tree91fa1dc0caaa82e1d3a2f6429d4b9dc6615b91ec /meta-netboot
parenta2953a19b6c846d054ea29fad8a74e44f8bd4920 (diff)
meta-agl-netboot: increase IMAGE_ROOTFS_EXTRA_SPACE
More room is needed when installing debug packages or big components like Chromium. Also, IMAGE_ROOTFS_EXTRA_SPACE was overridden by another unidentified configuration file or recipe: the setting is now forced. Consequently, the extra space must be reduced specifically for initrd. Change-Id: Id9b7659197c0840c04bce048a7bb1d96c77f3cc9 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9779 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-netboot')
-rw-r--r--meta-netboot/conf/include/agl-netboot.inc4
-rw-r--r--meta-netboot/recipes-core/images/initramfs-netboot-image.bb1
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-netboot/conf/include/agl-netboot.inc b/meta-netboot/conf/include/agl-netboot.inc
index 47f0c08a6..fcff8c318 100644
--- a/meta-netboot/conf/include/agl-netboot.inc
+++ b/meta-netboot/conf/include/agl-netboot.inc
@@ -1,5 +1,5 @@
INHERIT += "netboot"
OVERRIDES .= ":netboot"
-# add 256MB of extra space in ext4 output image
-IMAGE_ROOTFS_EXTRA_SPACE ?= "262144"
+# add 512MB of extra space in ext4 output image
+IMAGE_ROOTFS_EXTRA_SPACE = "524288"
diff --git a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
index 8b461e555..b9c8d2f75 100644
--- a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
+++ b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
@@ -15,5 +15,6 @@ IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "256"
BAD_RECOMMENDATIONS += "busybox-syslog"