summaryrefslogtreecommitdiffstats
path: root/meta-security/recipes-security/cynagora/cynagora_2.1.bb
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2020-11-12 09:11:45 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-11-18 12:22:48 +0000
commit6007c75b09ae81ca35e0f3ce97091818142d87dd (patch)
treec49f41b723fe8621fdd9a083ff7767b634588606 /meta-security/recipes-security/cynagora/cynagora_2.1.bb
parentad0c63129cfdd1553bae21e14445ef025d4c0808 (diff)
cynagora: Bump version 2.1
The version 2.1 fixes a critical database issue. Bug-AGL: SPEC-3677 Change-Id: I93fadbd1c12799d412724ea3e887d4910c74bbb1 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25552 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-security/recipes-security/cynagora/cynagora_2.1.bb')
-rw-r--r--meta-security/recipes-security/cynagora/cynagora_2.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-security/recipes-security/cynagora/cynagora_2.1.bb b/meta-security/recipes-security/cynagora/cynagora_2.1.bb
new file mode 100644
index 000000000..73f2f0949
--- /dev/null
+++ b/meta-security/recipes-security/cynagora/cynagora_2.1.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Cynagora service and client libraries"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cynagora;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "7d7907651c42c5c32deabc17b639e0e1765eae60"
+PV = "2.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "systemd libcap"
+
+inherit cmake
+
+EXTRA_OECMAKE += " \
+ -DSYSTEMD_UNIT_DIR=${systemd_system_unitdir} \
+ -DWITH_SYSTEMD=ON \
+ -DWITH_CYNARA_COMPAT=OFF \
+"
+
+inherit useradd
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "-r cynagora"
+USERADD_PARAM_${PN} = "\
+--system --home ${localstatedir}/lib/empty \
+--no-create-home --shell /bin/false \
+--gid cynagora cynagora \
+"
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+PACKAGES =+ "${PN}-tools"
+FILES_${PN}-tools += "${bindir}/cynagora-admin ${bindir}/cynagora-agent"
+RDEPENDS_${PN}_append_agl-devel = " ${PN}-tools"
+
+inherit ptest
+SRC_URI_append = " file://run-ptest"
+RDEPENDS_${PN}-ptest_append = " ${PN}-tools"