summaryrefslogtreecommitdiffstats
path: root/templates
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:12:45 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:59:52 +0000
commit1c3c06842ac1b9c089d0a08e91c60f44e4844fac (patch)
tree21e97368be8f78a3e76b66dfda24c1d5e774519f /templates
parentc1e048fc05542d859115990312e0753ce2dea72e (diff)
SPEC-3723: restructure meta-agl
Goal is to reach a minimal meta-agl-core as base for IVI and IC work at the same time. Trim dependencies and move most 'demo' related recipes to meta-agl-demo. v2: changed to bbapend + .inc , added description v3: testbuild of all images v4: restore -test packagegroup and -qa images, compare manifests and adapt packagegroups. v5: rebased v6: merged meta-agl-distro into meta-agl-core, due to dependency on meta-oe, moved -test packagegroup and -qa images to own layer meta-agl-core-test v7: Fixed comments from Paul Barker v8: Update the markdown files v9: restore wayland/weston/agl-compositor recipes/appends, reworked to move app f/w specific changes to bbappends in meta-app-framework and only demo specific weston-init changes to meta-agl-demo v10: fix s/agldemo/aglcore/ missed in weston-init.bbappend Description: This patch is part 1 out of 2 large patches that implement the layer rework discussed during the previous workshop. Essentially meta-agl-core is the small but versatile new core layer of AGL serving as basis for the work done by the IC and IVI EGs. All demo related work is moved to meta-agl-demo in the 2nd patchset. This should be applied together as atomic change. The resulting meta-agl/* follows these guidelines: - only bsp adaptations in meta-agl-bsp - remove the agl-profile-* layers for simplicity -- the packagegroup-agl(-profile)-graphical and so on have been kept in meta-agl-demo - meta-agl-profile-core is now meta-agl-core - meta-agl-core does pass yocto-check-layer -- therefore use the bbappend + conditional + .inc file construct found in meta-virtualization - meta-agl/meta-security has been merged into meta-agl/meta-app-framework - meta-netboot does pass yocto-check-layer - meta-pipewire does pass yocto-check-layer Migration: All packagegroups are preserved but they're now enabled by 'agl-demo'. Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia6c6e5e6ce2b4ffa69ea94959cdc57c310ba7c53 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25769
Diffstat (limited to 'templates')
-rw-r--r--templates/base/00_local.conf.agl.inc3
-rw-r--r--templates/base/99_local.conf.inc2
-rw-r--r--templates/base/bblayers.conf.sample20
-rw-r--r--templates/feature/agl-appfw-smack/50_bblayers.conf.inc9
-rw-r--r--templates/feature/agl-appfw-smack/50_local.conf.inc1
-rw-r--r--templates/feature/agl-hmi-framework/50_local.conf.inc2
-rw-r--r--templates/feature/agl-localdev/80_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-localdev/80_local.conf.inc2
-rw-r--r--templates/feature/agl-localdev/README_feature_agl-localdev.md9
-rw-r--r--templates/feature/agl-netboot/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-cluster-qt5/README_feature_agl-profile-cluster-qt5.md15
-rw-r--r--templates/feature/agl-profile-cluster-qt5/included.dep1
-rw-r--r--templates/feature/agl-profile-cluster/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-cluster/README_feature_agl-profile-cluster.md15
-rw-r--r--templates/feature/agl-profile-cluster/included.dep1
-rw-r--r--templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc6
-rw-r--r--templates/feature/agl-profile-graphical-html5/50_local.conf.inc3
-rw-r--r--templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md8
-rw-r--r--templates/feature/agl-profile-graphical-html5/included.dep1
-rw-r--r--templates/feature/agl-profile-graphical-qt5/50_bblayers.conf.inc9
-rw-r--r--templates/feature/agl-profile-graphical-qt5/README_feature_agl-profile-graphical-qt5.md15
-rw-r--r--templates/feature/agl-profile-graphical-qt5/included.dep1
-rw-r--r--templates/feature/agl-profile-graphical/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-graphical/README_feature_agl-profile-graphical.md9
-rw-r--r--templates/feature/agl-profile-hud/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-hud/README_feature_agl-profile-hud.md9
-rw-r--r--templates/feature/agl-profile-telematics/50_bblayers.conf.inc3
-rw-r--r--templates/feature/agl-profile-telematics/README_feature_agl-profile-telematics.md9
-rw-r--r--templates/feature/agl-weston-remoting/included.dep2
30 files changed, 32 insertions, 141 deletions
diff --git a/templates/base/00_local.conf.agl.inc b/templates/base/00_local.conf.agl.inc
index b49c44df6..d55cbef4b 100644
--- a/templates/base/00_local.conf.agl.inc
+++ b/templates/base/00_local.conf.agl.inc
@@ -6,6 +6,3 @@ DISTRO = "poky-agl"
#see meta-agl/meta-agl-profile-core/conf/include/base-agl.inc
require conf/include/base-agl.inc
-
-#see meta-agl/meta-app-framework/conf/include/agl-appfw-smack.inc
-require conf/include/agl-appfw-smack.inc
diff --git a/templates/base/99_local.conf.inc b/templates/base/99_local.conf.inc
index c4f43998b..bbf1b2afa 100644
--- a/templates/base/99_local.conf.inc
+++ b/templates/base/99_local.conf.inc
@@ -4,7 +4,7 @@
# ARM 32bit 'medium' compiler (armv7thf instead of armv7ve)
# (only use for CPUs <= cortex-a9 / w/o virt extension - e.g. cortex-a8)
-# DISTRO_FEATURES_append = " agl-medium-arm-compiler"
+# AGL_FEATURES_append = " agl-medium-arm-compiler"
######################
diff --git a/templates/base/bblayers.conf.sample b/templates/base/bblayers.conf.sample
index 653f6dbe8..0dd28da03 100644
--- a/templates/base/bblayers.conf.sample
+++ b/templates/base/bblayers.conf.sample
@@ -24,27 +24,15 @@ YOCTO_LAYERS = " \
# with some automotive tools/libraries
#-----------------------------------------------------
AGL_CORE_LAYERS = " \
- ${METADIR}/meta-agl/meta-agl-profile-core \
- ${METADIR}/meta-agl/meta-agl-distro \
+ ${METADIR}/meta-agl/meta-agl-core \
+ ${METADIR}/meta-agl/meta-agl-core-test \
${METADIR}/meta-agl/meta-agl-bsp \
"
-AGL_APPFW_LAYERS = " \
- ${METADIR}/external/meta-security \
- ${METADIR}/external/meta-openembedded/meta-perl \
- ${METADIR}/meta-agl/meta-security \
- ${METADIR}/meta-agl/meta-app-framework \
- "
-
-
# These are the direct dependencies of the AGL CORE Layers
#---------------------------------------------------------
AGL_CORE_DEPENDENCY_LAYERS = " \
${METADIR}/external/meta-openembedded/meta-oe \
- ${METADIR}/external/meta-openembedded/meta-multimedia \
- ${METADIR}/external/meta-openembedded/meta-networking \
- ${METADIR}/external/meta-openembedded/meta-python \
- ${METADIR}/external/meta-openembedded/meta-filesystems \
"
####################
@@ -52,15 +40,13 @@ AGL_CORE_DEPENDENCY_LAYERS = " \
BBLAYERS ?= " \
${AGL_CORE_DEPENDENCY_LAYERS} \
${AGL_CORE_LAYERS} \
- ${AGL_APPFW_LAYERS} \
${YOCTO_LAYERS} \
"
BBLAYERS_NON_REMOVABLE ?= " \
${METADIR}/external/poky/meta \
${METADIR}/external/poky/meta-poky \
- ${METADIR}/meta-agl/meta-agl-profile-core \
- ${METADIR}/meta-agl/meta-agl-distro \
+ ${METADIR}/meta-agl/meta-agl-core \
"
diff --git a/templates/feature/agl-appfw-smack/50_bblayers.conf.inc b/templates/feature/agl-appfw-smack/50_bblayers.conf.inc
new file mode 100644
index 000000000..5f6847a87
--- /dev/null
+++ b/templates/feature/agl-appfw-smack/50_bblayers.conf.inc
@@ -0,0 +1,9 @@
+AGL_APPFW_LAYERS = " \
+ ${METADIR}/external/meta-security \
+ ${METADIR}/external/meta-openembedded/meta-python \
+ ${METADIR}/external/meta-openembedded/meta-networking \
+ ${METADIR}/external/meta-openembedded/meta-perl \
+ ${METADIR}/meta-agl/meta-app-framework \
+ "
+
+BBLAYERS =+ "${AGL_APPFW_LAYERS}" \ No newline at end of file
diff --git a/templates/feature/agl-appfw-smack/50_local.conf.inc b/templates/feature/agl-appfw-smack/50_local.conf.inc
index e69de29bb..8282a1cae 100644
--- a/templates/feature/agl-appfw-smack/50_local.conf.inc
+++ b/templates/feature/agl-appfw-smack/50_local.conf.inc
@@ -0,0 +1 @@
+require conf/include/agl-appfw-smack.inc
diff --git a/templates/feature/agl-hmi-framework/50_local.conf.inc b/templates/feature/agl-hmi-framework/50_local.conf.inc
index d251e183d..21fdf3abf 100644
--- a/templates/feature/agl-hmi-framework/50_local.conf.inc
+++ b/templates/feature/agl-hmi-framework/50_local.conf.inc
@@ -1,4 +1,4 @@
# In order to enable the hmi-framework features ,
# enables the following line:
#
-DISTRO_FEATURES_append = " agl-hmi-framework"
+AGL_FEATURES_append = " agl-hmi-framework"
diff --git a/templates/feature/agl-localdev/80_bblayers.conf.inc b/templates/feature/agl-localdev/80_bblayers.conf.inc
new file mode 100644
index 000000000..d9bb9d070
--- /dev/null
+++ b/templates/feature/agl-localdev/80_bblayers.conf.inc
@@ -0,0 +1,3 @@
+# Local derivations during development, just add a layer in the folder meta-localdev
+BBLAYERS =+ "${@'${METADIR}/meta-localdev' if os.path.exists('${METADIR}/meta-localdev') else ''}"
+
diff --git a/templates/feature/agl-localdev/80_local.conf.inc b/templates/feature/agl-localdev/80_local.conf.inc
new file mode 100644
index 000000000..6c9213512
--- /dev/null
+++ b/templates/feature/agl-localdev/80_local.conf.inc
@@ -0,0 +1,2 @@
+# (weak) include userspecific local.dev.inc
+include local.dev.inc
diff --git a/templates/feature/agl-localdev/README_feature_agl-localdev.md b/templates/feature/agl-localdev/README_feature_agl-localdev.md
new file mode 100644
index 000000000..111ae4ec0
--- /dev/null
+++ b/templates/feature/agl-localdev/README_feature_agl-localdev.md
@@ -0,0 +1,9 @@
+---
+description: enable local layer for development purposes
+authors: Stéphane Desneux <stephane.desneux@iot.bzh>
+---
+
+### Feature agl-localdev
+
+Adds a local layer named "meta-localdev" in meta directory and a local.dev.inc conf file if present.
+
diff --git a/templates/feature/agl-netboot/50_bblayers.conf.inc b/templates/feature/agl-netboot/50_bblayers.conf.inc
index 3d2ed6460..80ace82d4 100644
--- a/templates/feature/agl-netboot/50_bblayers.conf.inc
+++ b/templates/feature/agl-netboot/50_bblayers.conf.inc
@@ -1 +1,2 @@
-BBLAYERS =+ "${METADIR}/meta-agl/meta-netboot"
+BBLAYERS =+ " ${METADIR}/meta-agl/meta-netboot \
+ "
diff --git a/templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc b/templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc
deleted file mode 100644
index f1aef074d..000000000
--- a/templates/feature/agl-profile-cluster-qt5/50_bblayers.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-cluster-qt5 \
-"
diff --git a/templates/feature/agl-profile-cluster-qt5/README_feature_agl-profile-cluster-qt5.md b/templates/feature/agl-profile-cluster-qt5/README_feature_agl-profile-cluster-qt5.md
deleted file mode 100644
index 095a8db18..000000000
--- a/templates/feature/agl-profile-cluster-qt5/README_feature_agl-profile-cluster-qt5.md
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-profile-cluster-qt5
-authors: Scott Murray <scott.murray@konsulko.com>
----
-
-### Feature agl-profile-cluster-qt5
-
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-cluster-qt5/README_feature_agl-profile-cluster-qt5.md*
-
-#### Dependent features pulled by agl-profile-cluster-qt5
-
-The following features are pulled:
-
-* agl-profile-graphical-qt5
-
diff --git a/templates/feature/agl-profile-cluster-qt5/included.dep b/templates/feature/agl-profile-cluster-qt5/included.dep
deleted file mode 100644
index 21b1fa6bc..000000000
--- a/templates/feature/agl-profile-cluster-qt5/included.dep
+++ /dev/null
@@ -1 +0,0 @@
-agl-profile-graphical-qt5
diff --git a/templates/feature/agl-profile-cluster/50_bblayers.conf.inc b/templates/feature/agl-profile-cluster/50_bblayers.conf.inc
deleted file mode 100644
index b430dc7db..000000000
--- a/templates/feature/agl-profile-cluster/50_bblayers.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-cluster \
-"
diff --git a/templates/feature/agl-profile-cluster/README_feature_agl-profile-cluster.md b/templates/feature/agl-profile-cluster/README_feature_agl-profile-cluster.md
deleted file mode 100644
index 544dc7c8e..000000000
--- a/templates/feature/agl-profile-cluster/README_feature_agl-profile-cluster.md
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-profile-cluster
-authors: Scott Murray <scott.murray@konsulko.com>
----
-
-### Feature agl-profile-cluster
-
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-cluster/README_feature_agl-profile-cluster.md*
-
-#### Dependent features pulled by agl-profile-cluster
-
-The following features are pulled:
-
-* agl-profile-graphical
-
diff --git a/templates/feature/agl-profile-cluster/included.dep b/templates/feature/agl-profile-cluster/included.dep
deleted file mode 100644
index 032609b8a..000000000
--- a/templates/feature/agl-profile-cluster/included.dep
+++ /dev/null
@@ -1 +0,0 @@
-agl-profile-graphical
diff --git a/templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc b/templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc
deleted file mode 100644
index a35f93fb5..000000000
--- a/templates/feature/agl-profile-graphical-html5/50_bblayers.conf.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-graphical-html5 \
- ${METADIR}/external/meta-python2 \
- "
-
diff --git a/templates/feature/agl-profile-graphical-html5/50_local.conf.inc b/templates/feature/agl-profile-graphical-html5/50_local.conf.inc
deleted file mode 100644
index 0b2d70028..000000000
--- a/templates/feature/agl-profile-graphical-html5/50_local.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-
-IMAGE_INSTALL_append = " packagegroup-agl-profile-graphical-html5"
-
diff --git a/templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md b/templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md
deleted file mode 100644
index dc00f94c2..000000000
--- a/templates/feature/agl-profile-graphical-html5/README_feature_agl-profile-graphical-html5.md
+++ /dev/null
@@ -1,8 +0,0 @@
----
-description: Feature agl-profile-graphical-html5
-authors: Jacobo Aragunde Pérez <jaragunde@igalia.com>
----
-
-### Feature agl-profile-graphical-html5
-
-Packages required to run web applications in AGL. The provided image agl-image-graphical-html5 includes the minimum set of packages required for this purpose.
diff --git a/templates/feature/agl-profile-graphical-html5/included.dep b/templates/feature/agl-profile-graphical-html5/included.dep
deleted file mode 100644
index 032609b8a..000000000
--- a/templates/feature/agl-profile-graphical-html5/included.dep
+++ /dev/null
@@ -1 +0,0 @@
-agl-profile-graphical
diff --git a/templates/feature/agl-profile-graphical-qt5/50_bblayers.conf.inc b/templates/feature/agl-profile-graphical-qt5/50_bblayers.conf.inc
deleted file mode 100644
index 960267908..000000000
--- a/templates/feature/agl-profile-graphical-qt5/50_bblayers.conf.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-graphical-qt5 \
-"
-
-# These are the dependencies
-#---------------------------
-BBLAYERS =+ " \
- ${METADIR}/external/meta-qt5 \
-"
diff --git a/templates/feature/agl-profile-graphical-qt5/README_feature_agl-profile-graphical-qt5.md b/templates/feature/agl-profile-graphical-qt5/README_feature_agl-profile-graphical-qt5.md
deleted file mode 100644
index 387de2ca4..000000000
--- a/templates/feature/agl-profile-graphical-qt5/README_feature_agl-profile-graphical-qt5.md
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-profile-graphical-qt5
-authors: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
-
-### Feature agl-profile-graphical-qt5
-
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-graphical-qt5/README_feature_agl-profile-graphical-qt5.md*
-
-#### Dependent features pulled by agl-profile-graphical-qt5
-
-The following features are pulled:
-
-* agl-profile-graphical
-
diff --git a/templates/feature/agl-profile-graphical-qt5/included.dep b/templates/feature/agl-profile-graphical-qt5/included.dep
deleted file mode 100644
index 5b54430da..000000000
--- a/templates/feature/agl-profile-graphical-qt5/included.dep
+++ /dev/null
@@ -1 +0,0 @@
-agl-profile-graphical \ No newline at end of file
diff --git a/templates/feature/agl-profile-graphical/50_bblayers.conf.inc b/templates/feature/agl-profile-graphical/50_bblayers.conf.inc
deleted file mode 100644
index 44b0885dc..000000000
--- a/templates/feature/agl-profile-graphical/50_bblayers.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-graphical \
-"
diff --git a/templates/feature/agl-profile-graphical/README_feature_agl-profile-graphical.md b/templates/feature/agl-profile-graphical/README_feature_agl-profile-graphical.md
deleted file mode 100644
index 594d047e7..000000000
--- a/templates/feature/agl-profile-graphical/README_feature_agl-profile-graphical.md
+++ /dev/null
@@ -1,9 +0,0 @@
----
-description: Feature agl-profile-graphical
-authors: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
-
-### Feature agl-profile-graphical
-
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-graphical/README_feature_agl-profile-graphical.md*
-
diff --git a/templates/feature/agl-profile-hud/50_bblayers.conf.inc b/templates/feature/agl-profile-hud/50_bblayers.conf.inc
deleted file mode 100644
index 047383710..000000000
--- a/templates/feature/agl-profile-hud/50_bblayers.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-hud \
-"
diff --git a/templates/feature/agl-profile-hud/README_feature_agl-profile-hud.md b/templates/feature/agl-profile-hud/README_feature_agl-profile-hud.md
deleted file mode 100644
index b4387c129..000000000
--- a/templates/feature/agl-profile-hud/README_feature_agl-profile-hud.md
+++ /dev/null
@@ -1,9 +0,0 @@
----
-description: Feature agl-profile-hud
-authors: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
-
-### Feature agl-profile-hud
-
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-hud/README_feature_agl-profile-hud.md*
-
diff --git a/templates/feature/agl-profile-telematics/50_bblayers.conf.inc b/templates/feature/agl-profile-telematics/50_bblayers.conf.inc
deleted file mode 100644
index 874b438f0..000000000
--- a/templates/feature/agl-profile-telematics/50_bblayers.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl/meta-agl-profile-telematics \
-"
diff --git a/templates/feature/agl-profile-telematics/README_feature_agl-profile-telematics.md b/templates/feature/agl-profile-telematics/README_feature_agl-profile-telematics.md
deleted file mode 100644
index 6abcd5d24..000000000
--- a/templates/feature/agl-profile-telematics/README_feature_agl-profile-telematics.md
+++ /dev/null
@@ -1,9 +0,0 @@
----
-description: Feature agl-profile-telematics
-authors: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
-
-### Feature agl-profile-telematics
-
-*Description is missing - please complete file meta-agl/templates/feature/agl-profile-telematics/README_feature_agl-profile-telematics.md*
-
diff --git a/templates/feature/agl-weston-remoting/included.dep b/templates/feature/agl-weston-remoting/included.dep
index 032609b8a..82639da07 100644
--- a/templates/feature/agl-weston-remoting/included.dep
+++ b/templates/feature/agl-weston-remoting/included.dep
@@ -1 +1 @@
-agl-profile-graphical
+agl-demo