aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi-eth-builtin.cfg3
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend3
-rw-r--r--meta-agl-distro/conf/distro/poky-agl.conf4
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb2
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0020-compositor-drm-get-stride-from-drm_get_dma_fd_from_view.patch59
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston_2.0.0.bbappend1
6 files changed, 69 insertions, 3 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi-eth-builtin.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi-eth-builtin.cfg
new file mode 100644
index 000000000..430d3206a
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi-eth-builtin.cfg
@@ -0,0 +1,3 @@
+CONFIG_USB_USBNET=y
+CONFIG_USB_NET_SMSC95XX=y
+CONFIG_USB_NET_SMSC75XX=y
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index 855a86257..dc2383b89 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -32,3 +32,6 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
# Enable bt hci uart
SRC_URI_append = " file://raspberrypi-hciuart.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
+
+SRC_URI_append = " file://raspberrypi-eth-builtin.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-eth-builtin.cfg"
diff --git a/meta-agl-distro/conf/distro/poky-agl.conf b/meta-agl-distro/conf/distro/poky-agl.conf
index d2bdb576f..a63c19f0b 100644
--- a/meta-agl-distro/conf/distro/poky-agl.conf
+++ b/meta-agl-distro/conf/distro/poky-agl.conf
@@ -10,8 +10,8 @@ DISTRO_CODENAME = "guppy"
AGL_BRANCH = "guppy"
AGLVERSION = "7.0.2"
# switch devel/release
-#AGLRELEASETYPE ?= "agldevelopment"
-AGLRELEASETYPE ?= "aglrelease"
+AGLRELEASETYPE ?= "agldevelopment"
+#AGLRELEASETYPE ?= "aglrelease"
OVERRIDES .= ":${AGLRELEASETYPE}"
#
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
index 24c7f2c35..32ae058c4 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://waltham-transmitter/COPYING;md5=f21c9af4de068fb53b83f
DEPENDS += "libdrm virtual/kernel wayland waltham weston gstreamer1.0 gstreamer gstreamer1.0-plugins-base gstreamer1.0-plugins-good"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/weston-ivi-plugins.git;protocol=https"
-SRCREV = "b84f9487a32e5b94c93d34a984858a93d0cefc57"
+SRCREV = "cd33a17ea5ac787786e5289ec914a96adeaf6346"
S = "${WORKDIR}/git/"
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0020-compositor-drm-get-stride-from-drm_get_dma_fd_from_view.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0020-compositor-drm-get-stride-from-drm_get_dma_fd_from_view.patch
new file mode 100644
index 000000000..8a691e447
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0020-compositor-drm-get-stride-from-drm_get_dma_fd_from_view.patch
@@ -0,0 +1,59 @@
+From 6e86c28fa61f8f80c9df6cad64af669fefc657c7 Mon Sep 17 00:00:00 2001
+From: Naoko Tanibata <tnaoko@jp.adit-jv.com>
+Date: Fri, 17 May 2019 21:37:21 +0900
+Subject: [PATCH 1/1] compositor-drm: get stride from drm_get_dma_fd_from_view
+
+Modify drm_get_dma_fd_from_view to get buffer stride.
+
+Signed-off-by: Veeresh Kadasani <external.vkadasani@jp.adit-jv.com>
+Signed-off-by: Naoko Tanibata <tnaoko@jp.adit-jv.com>
+---
+ libweston/compositor-drm.c | 4 +++-
+ libweston/compositor-drm.h | 2 +-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/libweston/compositor-drm.c b/libweston/compositor-drm.c
+index 0692aa8..b82e903 100644
+--- a/libweston/compositor-drm.c
++++ b/libweston/compositor-drm.c
+@@ -2645,7 +2645,7 @@ drm_output_set_seat(struct weston_output *base,
+
+ static int
+ drm_get_dma_fd_from_view(struct weston_output *base,
+- struct weston_view *ev)
++ struct weston_view *ev, int *buf_stride)
+ {
+ struct drm_backend *b = to_drm_backend(base->compositor);
+ struct weston_buffer *buffer = ev->surface->buffer_ref.buffer;
+@@ -2682,6 +2682,7 @@ drm_get_dma_fd_from_view(struct weston_output *base,
+ fprintf(stderr, "failed to get drm_handle\n");
+ return -1;
+ }
++ *buf_stride=gbm_dmabuf.stride;
+ }
+ else if(ev->surface->buffer_ref.buffer->legacy_buffer) {
+ bo = gbm_bo_import(b->gbm, GBM_BO_IMPORT_WL_BUFFER,
+@@ -2705,6 +2706,7 @@ drm_get_dma_fd_from_view(struct weston_output *base,
+ gbm_bo_destroy(bo);
+ return -1;
+ }
++ *buf_stride=current->stride;
+ }
+ else {
+ weston_log("Buffer is not supported\n");
+diff --git a/libweston/compositor-drm.h b/libweston/compositor-drm.h
+index 960b844..08122b2 100644
+--- a/libweston/compositor-drm.h
++++ b/libweston/compositor-drm.h
+@@ -84,7 +84,7 @@ struct weston_drm_output_api {
+ * The dma fd is got from weston_view.
+ * Returns fd on success, -1 on failure.
+ */
+- int (*get_dma_fd_from_view)(struct weston_output *output, struct weston_view *view);
++ int (*get_dma_fd_from_view)(struct weston_output *output, struct weston_view *view, int *buf_stride);
+ };
+
+ static inline const struct weston_drm_output_api *
+--
+2.7.4
+
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_2.0.0.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_2.0.0.bbappend
index c0a301ec1..574a94088 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_2.0.0.bbappend
@@ -22,6 +22,7 @@ SRC_URI_append = "\
file://0018-compositor-add-output-type-to-weston_output.patch \
file://0019-compositor-drm-introduce-drm_get_dmafd_from_view.patch \
file://use-XDG_RUNTIMESHARE_DIR.patch \
+ file://0020-compositor-drm-get-stride-from-drm_get_dma_fd_from_view.patch \
"
EXTRA_OECONF_append = " --enable-sys-uid"