summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-core/conf/include/agl-devel.inc2
-rw-r--r--meta-agl-core/conf/local.conf.sample2
-rw-r--r--meta-agl-core/conf/templates/base/local.conf.sample2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb42
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf3
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-stream-pipewire.service24
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/core.cfg1
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston_14_aglcore.inc7
-rw-r--r--templates/feature/agl-weston-remoting/50_local.conf.inc1
-rw-r--r--templates/feature/agl-weston-remoting/README_feature_agl-weston-remoting.md9
11 files changed, 77 insertions, 18 deletions
diff --git a/meta-agl-core/conf/include/agl-devel.inc b/meta-agl-core/conf/include/agl-devel.inc
index 055fa61e3..fd78fd158 100644
--- a/meta-agl-core/conf/include/agl-devel.inc
+++ b/meta-agl-core/conf/include/agl-devel.inc
@@ -1,4 +1,4 @@
-IMAGE_FEATURES =+ "debug-tweaks tools-debug tools-profile"
+IMAGE_FEATURES =+ "allow-empty-password empty-root-password allow-root-login post-install-logging tools-debug tools-profile"
IMAGE_INSTALL:append = " \
packagegroup-agl-core-devel \
diff --git a/meta-agl-core/conf/local.conf.sample b/meta-agl-core/conf/local.conf.sample
index 4cfae4ceb..e05f3c355 100644
--- a/meta-agl-core/conf/local.conf.sample
+++ b/meta-agl-core/conf/local.conf.sample
@@ -139,7 +139,7 @@ PACKAGE_CLASSES ?= "package_rpm"
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= ""
#
# Additional image features
diff --git a/meta-agl-core/conf/templates/base/local.conf.sample b/meta-agl-core/conf/templates/base/local.conf.sample
index 5e9de61b3..034988e4b 100644
--- a/meta-agl-core/conf/templates/base/local.conf.sample
+++ b/meta-agl-core/conf/templates/base/local.conf.sample
@@ -140,7 +140,7 @@ PACKAGE_CLASSES ?= "package_rpm"
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= ""
#
# Additional image features
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
new file mode 100644
index 000000000..f1d73732a
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
@@ -0,0 +1,42 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/agl-compositor-init:"
+
+SUMMARY = "Startup systemd unit for the AGL Wayland compositor with starting in the same time the DRM and PipeWire backends"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit systemd
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "file://agl-compositor-pipewire.conf \
+ file://agl-compositor-stream-pipewire.service \
+"
+
+S = "${WORKDIR}"
+
+AGL_KVM_REMOTE_OUTPUT_IP ?= "172.16.10.3"
+AGL_KVM_REMOTE_OUTPUT_PORT ?= "5005"
+
+do_install() {
+ sed -i -e "s,@REMOTE_OUTPUT_IP@,${AGL_KVM_REMOTE_OUTPUT_IP},g" \
+ ${WORKDIR}/agl-compositor-stream-pipewire.service
+
+ sed -i -e "s,@REMOTE_OUTPUT_PORT@,${AGL_KVM_REMOTE_OUTPUT_PORT},g" \
+ ${WORKDIR}/agl-compositor-stream-pipewire.service
+
+ install -D -p -m0644 ${WORKDIR}/agl-compositor-stream-pipewire.service ${D}${systemd_system_unitdir}/agl-compositor-stream-pipewire.service
+
+ install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
+ install -m644 ${WORKDIR}/agl-compositor-pipewire.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/02-agl-compositor.conf
+}
+
+FILES:${PN} += "\
+ ${systemd_system_unitdir}/agl-compositor.service.d \
+ ${systemd_system_unitdir}/agl-compositor.service.d/02-agl-compositor.conf \
+ ${systemd_system_unitdir}/agl-compositor-stream-pipewire.service \
+ "
+
+RDEPENDS:${PN} = "agl-compositor-init weston-ini"
+RCONFLICTS:${PN} = "weston-init"
+
+SYSTEMD_SERVICE:${PN} = "agl-compositor-stream-pipewire.service"
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
index 8400bc918..38cd59e47 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
@@ -42,7 +42,7 @@ do_install() {
fi
done
install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
- install -m644 ${WORKDIR}/agl-compositor.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/agl-compositor.conf
+ install -m644 ${WORKDIR}/agl-compositor.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/01-agl-compositor.conf
}
FILES:${PN} += "\
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf
new file mode 100644
index 000000000..aba0df102
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-pipewire.conf
@@ -0,0 +1,3 @@
+[Service]
+ExecStart=
+ExecStart=/usr/bin/agl-compositor -Bdrm,pipewire --idle-time=0 --config /etc/xdg/weston/weston.ini
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-stream-pipewire.service b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-stream-pipewire.service
new file mode 100644
index 000000000..949162c22
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init/agl-compositor-stream-pipewire.service
@@ -0,0 +1,24 @@
+[Unit]
+Description=Stream PipeWire output created by AGL compositor
+
+Requires=agl-compositor.service
+After=agl-compositor.service
+
+Before=graphical.target
+ConditionPathExists=/usr/bin/agl-stream-pipewire-output
+
+[Service]
+Type=simple
+EnvironmentFile=-/etc/default/agl-stream-pipewire-output
+ExecStart=/usr/bin/agl-stream-pipewire-output @REMOTE_OUTPUT_IP@ @REMOTE_OUTPUT_PORT@
+
+User=agl-driver
+Group=agl-driver
+
+WorkingDirectory=/home/agl-driver
+
+StandardOutput=journal
+StandardError=journal
+
+[Install]
+WantedBy=graphical.target
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/core.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/core.cfg
index 28f90752d..278db8956 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/core.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/core.cfg
@@ -1,5 +1,4 @@
[core]
-backend=drm-backend.so
require-input=false
idle-time=0
modules=systemd-notify.so
diff --git a/meta-agl-core/recipes-graphics/wayland/weston_14_aglcore.inc b/meta-agl-core/recipes-graphics/wayland/weston_14_aglcore.inc
index 14387898e..800fb5984 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston_14_aglcore.inc
+++ b/meta-agl-core/recipes-graphics/wayland/weston_14_aglcore.inc
@@ -1,11 +1,11 @@
FILESEXTRAPATHS:append := ":${THISDIR}/weston"
-PACKAGECONFIG:append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
-
SRC_URI:append = " \
file://0001-clients-Handle-missing-pointer_surface-is-there-s-no.patch \
"
+PACKAGECONFIG:append = " pipewire "
+WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
# Split weston-terminal out of the main package to allow installing it
# separately for use with other compositors. The icons, etc. that end
@@ -14,8 +14,9 @@ SRC_URI:append = " \
# packaged in weston-examples in addition to ivi-shell in the main
# package.
-PACKAGE_BEFORE_PN += "${PN}-data ${PN}-terminal"
+PACKAGE_BEFORE_PN += "${PN}-data ${PN}-terminal ${PN}-pipewire"
+FILES:${PN}-pipewire = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/pipewire-backend.so"
FILES:${PN}-data = "${datadir}/weston"
FILES:${PN}-terminal = "${bindir}/weston-terminal"
diff --git a/templates/feature/agl-weston-remoting/50_local.conf.inc b/templates/feature/agl-weston-remoting/50_local.conf.inc
deleted file mode 100644
index 63e0a984a..000000000
--- a/templates/feature/agl-weston-remoting/50_local.conf.inc
+++ /dev/null
@@ -1 +0,0 @@
-DISTRO_FEATURES:append = " weston-remoting"
diff --git a/templates/feature/agl-weston-remoting/README_feature_agl-weston-remoting.md b/templates/feature/agl-weston-remoting/README_feature_agl-weston-remoting.md
deleted file mode 100644
index 03b05d496..000000000
--- a/templates/feature/agl-weston-remoting/README_feature_agl-weston-remoting.md
+++ /dev/null
@@ -1,9 +0,0 @@
----
-description: Feature agl-weston-remoting
-authors: Scott Murray <scott.murray@konsulko.com>
----
-
-### Feature agl-weston-remoting
-
-Enables secondary remote display configuration using Weston's remoting feaure.
-