summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc3
-rw-r--r--meta-agl-bsp/conf/include/agl_m3ulcb.inc3
-rw-r--r--meta-agl-bsp/conf/include/agl_porter-nogfx.inc5
-rw-r--r--meta-agl-bsp/conf/include/agl_porter.inc5
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/files/uEnv-ota.txt19
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb25
6 files changed, 54 insertions, 6 deletions
diff --git a/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc b/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
index 35ed8ba43..d67be93c5 100644
--- a/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
@@ -10,3 +10,6 @@ BBMASK = "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
BBMASK .= "|kernel-module-uvcs-drv|omx-user-module"
BBMASK .= "|meta-renesas-rcar-gen3/meta-rcar-gen3/recipes-forward-port/"
+
+OSTREE_KERNEL = "Image"
+IMAGE_BOOT_FILES_sota = "m3ulcb-ota-bootfiles/* Image-r8a7796-m3ulcb.dtb"
diff --git a/meta-agl-bsp/conf/include/agl_m3ulcb.inc b/meta-agl-bsp/conf/include/agl_m3ulcb.inc
index 90e029287..de59df113 100644
--- a/meta-agl-bsp/conf/include/agl_m3ulcb.inc
+++ b/meta-agl-bsp/conf/include/agl_m3ulcb.inc
@@ -47,3 +47,6 @@ IMAGE_INSTALL_append_rcar-gen3 = " \
"
BBMASK .= "|meta-renesas-rcar-gen3/meta-rcar-gen3/recipes-forward-port/"
+
+OSTREE_KERNEL = "Image"
+IMAGE_BOOT_FILES_sota = "m3ulcb-ota-bootfiles/* Image-r8a7796-m3ulcb.dtb"
diff --git a/meta-agl-bsp/conf/include/agl_porter-nogfx.inc b/meta-agl-bsp/conf/include/agl_porter-nogfx.inc
index 6bc517191..dd2ab85ae 100644
--- a/meta-agl-bsp/conf/include/agl_porter-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_porter-nogfx.inc
@@ -22,7 +22,6 @@ PREFERRED_PROVIDER_virtual/egl = "mesa"
# Commit united image to OSTree, not just uImage
OSTREE_KERNEL = "uImage+dtb"
-# OTA-enabled live image
-IMAGE_CLASSES_append_sota = " image_types_uboot sdcard_image-porter-ota"
-IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-ota', 'porter-sdimg-ota ', '', d)}"
+IMAGE_CLASSES_append_sota = " image_types_uboot "
+IMAGE_BOOT_FILES_sota = "porter-bootfiles/*"
diff --git a/meta-agl-bsp/conf/include/agl_porter.inc b/meta-agl-bsp/conf/include/agl_porter.inc
index a3f2aac5a..4837ced8d 100644
--- a/meta-agl-bsp/conf/include/agl_porter.inc
+++ b/meta-agl-bsp/conf/include/agl_porter.inc
@@ -182,7 +182,6 @@ DISTRO_FEATURES_append = " h264avcenc_lib"
# Commit united image to OSTree, not just uImage
OSTREE_KERNEL = "uImage+dtb"
-# OTA-enabled live image
-IMAGE_CLASSES_append_sota = " image_types_uboot sdcard_image-porter-ota"
-IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-ota', 'porter-sdimg-ota ', '', d)}"
+IMAGE_CLASSES_append_sota = " image_types_uboot "
+IMAGE_BOOT_FILES_sota = "porter-bootfiles/*"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/files/uEnv-ota.txt b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/files/uEnv-ota.txt
new file mode 100644
index 000000000..87d362a37
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/files/uEnv-ota.txt
@@ -0,0 +1,19 @@
+bootkaddr=0x49090000
+bootdaddr=0x48000000
+bootiaddr=0x5C3F9520
+
+bootargs_console=console=ttySC0,115200 ignore_loglevel
+bootargs_extra=rw rootfstype=ext4 rootwait rootdelay=2
+bootargs_video=vmalloc=384M video=HDMI-A-1:1280x960-32@60
+bootargs_root=ostree_root=/dev/mmcblk1p2 root=/dev/ram0 ramdisk_size=16384
+
+bootmmc=0:1
+rootmmc=0:2
+
+booteload_sd=ext4load mmc ${rootmmc} ${bootkaddr} boot/loader/uEnv.txt; env import -t ${bootkaddr} ${filesize}
+bootkload_sd=ext4load mmc ${rootmmc} ${bootkaddr} boot/${kernel_image}
+bootiload_sd=ext4load mmc ${rootmmc} ${bootiaddr} boot/${ramdisk_image}; setenv ramdisk_size ${filesize}
+bootdload_sd=fatload mmc ${bootmmc} ${bootdaddr} Image-r8a7796-m3ulcb.dtb
+
+bootcmd=run booteload_sd; setenv bootargs ${bootargs} ${bootargs_video} ${bootargs_console} ${bootargs_root} ${bootargs_extra}; run bootkload_sd; run bootiload_sd; run bootdload_sd; booti ${bootkaddr} ${bootiaddr}:${ramdisk_size} ${bootdaddr}
+
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb
new file mode 100644
index 000000000..f0e04c06a
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/bootfiles/m3ulcb-ota-bootfiles.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Boot files (bootscripts etc.) for Renesas RCar-M3 board"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit deploy
+
+COMPATIBLE_MACHINE = "m3ulcb"
+
+S = "${WORKDIR}"
+
+SRC_URI_append_sota = "file://uEnv-ota.txt"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+}
+
+do_deploy_append_sota() {
+ install -m 0755 ${WORKDIR}/uEnv-ota.txt ${DEPLOYDIR}/${PN}/uEnv.txt
+}
+
+addtask deploy before do_package after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+