summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
index 9fa8dd8f8..98b973caa 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
@@ -1,3 +1,15 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-rcar.ini \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-rcar.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
FILES_${PN}_append_rcar-gen3 = " \
${libexecdir}/weston-screenshooter \
${libexecdir}/weston-ivi-shell-user-interface \
@@ -6,4 +18,6 @@ FILES_${PN}_append_rcar-gen3 = " \
${libexecdir}/weston-desktop-shell \
"
-SRC_URI_remove = "file://fix-touchscreen-crash.patch"
+FILES_${PN}_append = " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ "