summaryrefslogtreecommitdiffstats
path: root/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb')
-rw-r--r--meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb b/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb
new file mode 100644
index 000000000..a8b93716a
--- /dev/null
+++ b/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb
@@ -0,0 +1,24 @@
+SUMMARY = "ipv6connect test"
+HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/0.12.369.B/client/tests/ipv6connect"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${S}/${PN}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "b355b7e1f43a19938895964f314484ffd8a39542"
+
+inherit autotools
+
+INSANE_SKIP_${PN} = "ldflags"
+
+B = "${WORKDIR}/git/ipv6connect"
+S = "${WORKDIR}/git"
+
+# configure script is not delivered, only a makefile.
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${B}/ipv6connect ${D}${bindir}
+}