summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb')
-rw-r--r--meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb b/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
new file mode 100644
index 000000000..7b6d50531
--- /dev/null
+++ b/meta-agl-core/recipes-connectivity/connman-ncurses/connman-ncurses_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "A simple ncurses interface for connman"
+DESCRIPTION = "A simple ncurses interface for connman"
+HOMEPAGE = "https://gitlab.com/iotbzh/connman-json-client"
+
+SECTION = "console/network"
+
+DEPENDS = "dbus ncurses connman json-c"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
+
+SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;branch=master \
+ file://stdbool-fixes.patch \
+ file://0001-Do-not-overwrite-CFLAGS.patch \
+ file://0001-Initialize-variables.patch \
+ "
+SRCREV = "2b0f93ec9518c978c04807fe52e95315d6d80e6b"
+
+inherit autotools pkgconfig
+
+EXTRA_AUTORECONF += " -vfi"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -dm755 ${D}${bindir}
+ install -Dm755 connman_ncurses ${D}${bindir}
+}
+
+FILES:${PN} = "${bindir}/connman_ncurses"