summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb')
-rw-r--r--meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb b/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
new file mode 100644
index 000000000..bc708600f
--- /dev/null
+++ b/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Security middleware components"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+# Install Cynara and security-manager by default if (and only if)
+# Smack is enabled.
+#
+# Cynara does not have a hard dependency on Smack security,
+# but is meant to be used with it. security-manager however
+# links against smack and expects Smack to be active,
+# so we do not have any choice.
+#
+# Without configuration, security-manager is not usable. We use
+# the policy packaged from the upstream source code here. Adapting
+# it for the distro can be done by patching that source.
+RDEPENDS_${PN}_append_with-lsm-smack = " \
+ cynagora \
+ security-manager \
+ security-manager-policy \
+ smacknet \
+ smack-system-setup \
+"