From 2f1298383c1fba5121dfeeff1f31ae4004703dae Mon Sep 17 00:00:00 2001
From: Scott Murray <scott.murray@konsulko.com>
Date: Fri, 30 Sep 2022 15:03:24 -0400
Subject: Add Yocto Project scarthgap release compatibility

Switch to scarthgap in LAYERSERIES_COMPAT in layer.conf files.

Bug-AGL: SPEC-4578

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I2c690c02a55bb0ddca9231bdf405a5f21486db3f
---
 meta-agl-bsp/conf/layer.conf                     | 2 +-
 meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf | 2 +-
 meta-agl-core/conf/layer.conf                    | 2 +-
 meta-app-framework/conf/layer.conf               | 2 +-
 meta-netboot/conf/layer.conf                     | 2 +-
 meta-pipewire/conf/layer.conf                    | 2 +-
 6 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
index cd98a9dfc..036cde7a7 100644
--- a/meta-agl-bsp/conf/layer.conf
+++ b/meta-agl-bsp/conf/layer.conf
@@ -23,4 +23,4 @@ BBFILE_COLLECTIONS += "aglbsp"
 BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
 BBFILE_PRIORITY_aglbsp = "60"
 
-LAYERSERIES_COMPAT_aglbsp = "kirkstone"
+LAYERSERIES_COMPAT_aglbsp = "scarthgap"
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
index be6f0aa25..bae421a50 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
@@ -15,4 +15,4 @@ BBFILE_COLLECTIONS += "rcar-gen3-cogent"
 BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/"
 BBFILE_PRIORITY_rcar-gen3-cogent = "7"
 
-LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone"
+LAYERSERIES_COMPAT_rcar-gen3-cogent = "scarthgap"
diff --git a/meta-agl-core/conf/layer.conf b/meta-agl-core/conf/layer.conf
index ddea256fe..8047df519 100644
--- a/meta-agl-core/conf/layer.conf
+++ b/meta-agl-core/conf/layer.conf
@@ -20,7 +20,7 @@ BBFILES_DYNAMIC += " \
     qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bbappend \
 "
 
-LAYERSERIES_COMPAT_aglcore = "kirkstone"
+LAYERSERIES_COMPAT_aglcore = "scarthgap"
 LAYERDEPENDS_aglcore = "core"
 
 # Sanity check for meta-virtualization layer.
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
index 85565353e..0fe82784b 100644
--- a/meta-app-framework/conf/layer.conf
+++ b/meta-app-framework/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-app-framework"
 BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-app-framework = "60"
 
-LAYERSERIES_COMPAT_meta-app-framework = "kirkstone"
+LAYERSERIES_COMPAT_meta-app-framework = "scarthgap"
 LAYERDEPENDS_meta-app-framework = "core aglcore openembedded-layer"
diff --git a/meta-netboot/conf/layer.conf b/meta-netboot/conf/layer.conf
index ddf63c4a2..a41406cbb 100644
--- a/meta-netboot/conf/layer.conf
+++ b/meta-netboot/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-netboot"
 BBFILE_PATTERN_meta-netboot = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-netboot = "60"
 
-LAYERSERIES_COMPAT_meta-netboot = "kirkstone"
+LAYERSERIES_COMPAT_meta-netboot = "scarthgap"
 LAYERDEPENDS_meta-netboot = "core networking-layer"
diff --git a/meta-pipewire/conf/layer.conf b/meta-pipewire/conf/layer.conf
index 639a3ef43..4a28a4244 100644
--- a/meta-pipewire/conf/layer.conf
+++ b/meta-pipewire/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "meta-pipewire"
 BBFILE_PATTERN_meta-pipewire = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-pipewire = "71"
 
-LAYERSERIES_COMPAT_meta-pipewire = "kirkstone"
+LAYERSERIES_COMPAT_meta-pipewire = "scarthgap"
 LAYERDEPENDS_meta-pipewire = "openembedded-layer"
 
 #
-- 
cgit