From 4c67a503983f0547a8bcd253122367bec6b20982 Mon Sep 17 00:00:00 2001
From: Scott Murray <scott.murray@konsulko.com>
Date: Mon, 27 Jan 2020 14:29:49 -0500
Subject: meta-agl-bsp: handle ptest-runner upgrade

Rename ptest-runner to handle upgrade from 2.2 to 2.3.2, and update
local LAVA support patch.

Bug-AGL: SPEC-2932

Change-Id: Ia9edf303de689c42bad80a04522117c27e0977c2
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
---
 .../0007-WIP-Initial-LAVA-support.patch            | 56 ++++++++++------------
 .../ptest-runner/ptest-runner_2.%.bbappend         |  4 ++
 .../ptest-runner/ptest-runner_2.2.bbappend         |  4 --
 3 files changed, 30 insertions(+), 34 deletions(-)
 create mode 100644 meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.%.bbappend
 delete mode 100644 meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.2.bbappend

diff --git a/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner/0007-WIP-Initial-LAVA-support.patch b/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner/0007-WIP-Initial-LAVA-support.patch
index 28c9c09bf..6232c4fa4 100644
--- a/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner/0007-WIP-Initial-LAVA-support.patch
+++ b/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner/0007-WIP-Initial-LAVA-support.patch
@@ -18,17 +18,12 @@ emitted to stdout:
 It is valid to have a measurement without units, but not units without a measurement.
 
 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
+[updated for ptest-runner 2.3.2]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
 ---
- flags.h | 10 ++++++++++
- main.c  |  9 ++++++++-
- utils.c | 15 +++++++++++++++
- utils.h |  2 +-
- 4 files changed, 34 insertions(+), 2 deletions(-)
- create mode 100644 flags.h
-
 diff --git a/flags.h b/flags.h
 new file mode 100644
-index 000000000000..0dac2234e0b4
+index 0000000..0dac223
 --- /dev/null
 +++ b/flags.h
 @@ -0,0 +1,10 @@
@@ -43,18 +38,18 @@ index 000000000000..0dac2234e0b4
 +
 +#endif				/* __FLAGS_H__ */
 diff --git a/main.c b/main.c
-index 83600b7d1b31..92ced6926c3d 100644
+index 01d60f7..165370f 100644
 --- a/main.c
 +++ b/main.c
-@@ -36,6 +36,7 @@
+@@ -38,6 +38,7 @@
  #endif
  
  #include "utils.h"
 +#include "flags.h"
  
+ #ifndef DEFAULT_DIRECTORY
  #define DEFAULT_DIRECTORY "/usr/lib"
- #define DEFAULT_TIMEOUT 300
-@@ -70,8 +71,9 @@ main(int argc, char *argv[])
+@@ -74,8 +75,9 @@ main(int argc, char *argv[])
  	opts.timeout = DEFAULT_TIMEOUT;
  	opts.ptests = NULL;
  	opts.xml_filename = NULL;
@@ -65,7 +60,7 @@ index 83600b7d1b31..92ced6926c3d 100644
  		switch (opt) {
  			case 'd':
  				free(opts.directory);
-@@ -118,6 +120,11 @@ main(int argc, char *argv[])
+@@ -122,6 +124,11 @@ main(int argc, char *argv[])
  				opts.xml_filename = strdup(optarg);
  				CHECK_ALLOCATION(opts.xml_filename, 1, 1);
  			break;
@@ -78,10 +73,10 @@ index 83600b7d1b31..92ced6926c3d 100644
  				print_usage(stdout, argv[0]);
  				exit(1);
 diff --git a/utils.c b/utils.c
-index ed2eff7900c1..0fd1da6aec92 100644
+index a8ba190..19f9efa 100644
 --- a/utils.c
 +++ b/utils.c
-@@ -39,6 +39,7 @@
+@@ -47,6 +47,7 @@
  
  #include "ptest_list.h"
  #include "utils.h"
@@ -89,30 +84,34 @@ index ed2eff7900c1..0fd1da6aec92 100644
  
  #define GET_STIME_BUF_SIZE 1024
  #define WAIT_CHILD_POLL_TIMEOUT_MS 200
-@@ -358,6 +359,7 @@ run_ptests(struct ptest_list *head, const struct ptest_options opts,
+@@ -439,6 +440,7 @@ run_ptests(struct ptest_list *head, const struct ptest_options opts,
  		fprintf(fp, "START: %s\n", progname);
- 		PTEST_LIST_ITERATE_START(head, p);
+ 		PTEST_LIST_ITERATE_START(head, p)
  			char *ptest_dir = strdup(p->run_ptest);
 +			char *ptest = strdup(p->ptest);
  			if (ptest_dir == NULL) {
  				rc = -1;
  				break;
-@@ -376,6 +378,11 @@ run_ptests(struct ptest_list *head, const struct ptest_options opts,
+@@ -480,11 +482,15 @@ run_ptests(struct ptest_list *head, const struct ptest_options opts,
+ 				int status;
  				int fds[2]; fds[0] = pipefd_stdout[0]; fds[1] = pipefd_stderr[0];
  				FILE *fps[2]; fps[0] = fp; fps[1] = fp_stderr;
- 
 +				char result[5]; // pass\0, fail\0, skip\0
-+
+ 
+ 				if (setpgid(child, pgid) == -1) {
+ 					fprintf(fp, "ERROR: setpgid() failed, %s\n", strerror(errno));
+ 				}
+ 
 +				if (opts.flags & LAVA_SIGNAL_ENABLE) {
 +					fprintf(stdout, "<LAVA_SIGNAL_STARTTC %s>\n", ptest);
 +				}
- 				fprintf(fp, "%s\n", get_stime(stime, GET_STIME_BUF_SIZE));
+ 				sttime = time(NULL);
+ 				fprintf(fp, "%s\n", get_stime(stime, GET_STIME_BUF_SIZE, sttime));
  				fprintf(fp, "BEGIN: %s\n", ptest_dir);
- 
-@@ -389,6 +396,14 @@ run_ptests(struct ptest_list *head, const struct ptest_options opts,
+@@ -506,6 +512,14 @@ run_ptests(struct ptest_list *head, const struct ptest_options opts,
  
  				fprintf(fp, "END: %s\n", ptest_dir);
- 				fprintf(fp, "%s\n", get_stime(stime, GET_STIME_BUF_SIZE));
+ 				fprintf(fp, "%s\n", get_stime(stime, GET_STIME_BUF_SIZE, entime));
 +				if (opts.flags & LAVA_SIGNAL_ENABLE) {
 +					if (status)
 +						sprintf(result, "fail");
@@ -122,13 +121,13 @@ index ed2eff7900c1..0fd1da6aec92 100644
 +					fprintf(stdout, "<LAVA_SIGNAL_TESTCASE TEST_CASE_ID=%s RESULT=%s>\n", ptest, result);
 +				}
  			}
- 		PTEST_LIST_ITERATE_END;
+ 		PTEST_LIST_ITERATE_END
  		fprintf(fp, "STOP: %s\n", progname);
 diff --git a/utils.h b/utils.h
-index ee85163ddfff..06d4c100d151 100644
+index aa53707..df11e24 100644
 --- a/utils.h
 +++ b/utils.h
-@@ -37,9 +37,9 @@ struct ptest_options {
+@@ -39,9 +39,9 @@ struct ptest_options {
  	int timeout;
  	char **ptests;
  	char *xml_filename;
@@ -139,6 +138,3 @@ index ee85163ddfff..06d4c100d151 100644
  extern void check_allocation1(void *, size_t, char *, int, int);
  extern struct ptest_list *get_available_ptests(const char *);
  extern int print_ptests(struct ptest_list *, FILE *);
--- 
-2.11.0
-
diff --git a/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.%.bbappend b/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.%.bbappend
new file mode 100644
index 000000000..7a1d2a8f8
--- /dev/null
+++ b/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0007-WIP-Initial-LAVA-support.patch"
+
diff --git a/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.2.bbappend b/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.2.bbappend
deleted file mode 100644
index 7a1d2a8f8..000000000
--- a/meta-agl-bsp/recipes-support/ptest-runner/ptest-runner_2.2.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://0007-WIP-Initial-LAVA-support.patch"
-
-- 
cgit