From 1c5e1f26af6e8b91115b45630902381051468dfa Mon Sep 17 00:00:00 2001
From: Corentin Labbe <clabbe@baylibre.com>
Date: Fri, 12 Apr 2019 13:11:44 +0000
Subject: meta-intel: Support the upsquare board

This patch adds the necessary CONFIG for booting the upsquare board.

The upsquare have an R8169 ethernet card and need it built-in for
the kernel DHCP autoconf to work.

The upsquare need some MFD_INTEL configs to boot.

The meta-intel miss some CONFIG necessary for LAVA and NBD to works.

Bug-AGL: SPEC-2075

Change-Id: I990732c78b53ac591dde83f4e372b420ea558fa7
Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
---
 .../meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend    | 8 ++++++++
 1 file changed, 8 insertions(+)

(limited to 'meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend')

diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
index 62c264d12..e159747ae 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
@@ -12,6 +12,14 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
 SRC_URI_append = " file://net-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
 
+# adding specific driver needed by the upsquare board
+SRC_URI_append = " file://upsquare.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/upsquare.cfg"
+
+# adding CONFIG needed by LAVA and NBD
+SRC_URI_append = " file://lava.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/lava.cfg"
+
 # Ensure we have a startup.nsh file
 SRC_URI_append = " file://startup.nsh"
 
-- 
cgit 1.2.3-korg