From d140198f4775b631a46fef53c9a2c3fd42c3a6ea Mon Sep 17 00:00:00 2001
From: Martin Kelly <mkelly@xevo.com>
Date: Mon, 17 Jul 2017 10:56:57 -0700
Subject: af-main: add RDEPENDS on bash
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Currently, we get a file-rdeps QA warning because afm-install has a
/bin/bash shebang line but does not RDEPENDS on bash. We could also use
/bin/sh instead, but I'm not sure if we have some bashisms built-in to
the script. For now, add RDEPENDS to fix the warning.

Change-Id: I368da5e9e5c2d57d7bc2a1b674eb84c1147be5c1
Signed-off-by: Martin Kelly <mkelly@xevo.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10217
Reviewed-by: José Bollo <jobol@nonadev.net>
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
---
 meta-app-framework/recipes-core/af-main/af-main_1.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'meta-app-framework')

diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 33d380d05..7863874a2 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -45,7 +45,7 @@ SYSTEMD_AUTO_ENABLE = "enable"
 FILES_${PN} += "\
 	${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
 "
-RDEPENDS_${PN}_append_smack = " smack-userspace"
+RDEPENDS_${PN}_append_smack = " smack-userspace bash"
 DEPENDS_append_smack = " smack-userspace-native"
 
 # short hacks here
-- 
cgit