From f98e42dcd4b7b9dfc6b833c87105929d8f5868b0 Mon Sep 17 00:00:00 2001
From: José Bollo <jose.bollo@iot.bzh>
Date: Wed, 12 Jul 2017 13:32:23 +0200
Subject: systemd-udev: ensure convention for naming udev rules
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The udev rules files installed in /etc/udev/rules.d
should follow systemd naming convention.

This patch ensures it by renaming known wrong files
before to install it.

This patch is temporary.
This is a solution to the Bug-AGL SPEC-539.

It renames the file udev-smack-default.rules
as the file 55-smack-default.rules before installation in do_install.
This comes from https://github.com/01org/meta-intel-iot-security.git
(meta-security-smack/recipes-core/systemd/)
It should be removed when the security layer will be refited to meta-security
See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security

It also renames the file touchscreen.rules as the file 55-touchscreen.rules
This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd)
It should be removed when poky changes.

Bug-AGL: SPEC-539

Change-Id: I95e36fc22711babb185ccf53deee8b838874c401
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10167
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
---
 .../recipes-core/systemd/systemd_%.bbappend          | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-app-framework/recipes-core/systemd/systemd_%.bbappend

(limited to 'meta-app-framework')

diff --git a/meta-app-framework/recipes-core/systemd/systemd_%.bbappend b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 000000000..6b8057a5c
--- /dev/null
+++ b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,20 @@
+##################################################################################
+# This patch is temporary.
+# This is a solution to the Bug-AGL SPEC-539.
+#
+# It renames the file udev-smack-default.rules
+# as the file 55-smack-default.rules before installation in do_install.
+# This comes from https://github.com/01org/meta-intel-iot-security.git
+# (meta-security-smack/recipes-core/systemd/)
+# It should be removed when the security layer will be refited to meta-security
+# See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security
+#
+# It also renames the file touchscreen.rules as the file 55-touchscreen.rules
+# This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd)
+# It should be removed when poky changes.
+##################################################################################
+do_install_prepend() {
+	mv ${WORKDIR}/udev-smack-default.rules ${WORKDIR}/55-smack-default.rules || true
+	mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
+}
+
-- 
cgit