aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Barinov <vladimir.barinov@cogentembedded.com>2018-02-02 18:20:09 +0300
committerHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2018-03-06 15:34:33 +0900
commit07717e72efed0ec7c69bc5282ac0b21f4bba219a (patch)
tree345240534e1b5ad4577c9c9f7531ea453db947b7
parent5277a7c1c260e84eab172f5836d5881a8aa47f05 (diff)
The patch 0035-* breaks regulators on KF board. As a result the Multichannal audio was broken
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-regulator-fixed-probe-after-i2c.patch53
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_4.9.bbappend1
2 files changed, 0 insertions, 54 deletions
diff --git a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-regulator-fixed-probe-after-i2c.patch b/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-regulator-fixed-probe-after-i2c.patch
deleted file mode 100644
index 31c79ce..0000000
--- a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/0035-regulator-fixed-probe-after-i2c.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From ef0ae334de1e1b318f4fb26bc8045451318a60c4 Mon Sep 17 00:00:00 2001
-From: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
-Date: Sun, 26 Nov 2017 21:35:54 +0300
-Subject: [PATCH] regulator: fixed: probe after i2c
-
-This is a workaround for LVDS cameras that use I2C gpio expanders.
-Set fixed regulator booted after i2c expander to have PoC
-power controlled in LVDS driver.
-
-Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
----
- drivers/Makefile | 4 +++-
- drivers/regulator/fixed.c | 2 +-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/Makefile b/drivers/Makefile
-index 194d20b..f49ed8f 100644
---- a/drivers/Makefile
-+++ b/drivers/Makefile
-@@ -41,6 +41,8 @@ obj-y += soc/
- obj-$(CONFIG_VIRTIO) += virtio/
- obj-$(CONFIG_XEN) += xen/
-
-+obj-y += i2c/
-+
- # regulators early, since some subsystems rely on them to initialize
- obj-$(CONFIG_REGULATOR) += regulator/
-
-@@ -105,7 +107,7 @@ obj-$(CONFIG_SERIO) += input/serio/
- obj-$(CONFIG_GAMEPORT) += input/gameport/
- obj-$(CONFIG_INPUT) += input/
- obj-$(CONFIG_RTC_LIB) += rtc/
--obj-y += i2c/ media/
-+obj-y += media/
- obj-$(CONFIG_PPS) += pps/
- obj-$(CONFIG_PTP_1588_CLOCK) += ptp/
- obj-$(CONFIG_W1) += w1/
-diff --git a/drivers/regulator/fixed.c b/drivers/regulator/fixed.c
-index 988a747..44a169c 100644
---- a/drivers/regulator/fixed.c
-+++ b/drivers/regulator/fixed.c
-@@ -211,7 +211,7 @@ static int __init regulator_fixed_voltage_init(void)
- {
- return platform_driver_register(&regulator_fixed_voltage_driver);
- }
--subsys_initcall(regulator_fixed_voltage_init);
-+module_init(regulator_fixed_voltage_init);
-
- static void __exit regulator_fixed_voltage_exit(void)
- {
---
-1.9.1
-
diff --git a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_4.9.bbappend b/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_4.9.bbappend
index c4cad0f..c02731a 100644
--- a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_4.9.bbappend
+++ b/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_4.9.bbappend
@@ -50,7 +50,6 @@ SRC_URI_append = " \
file://0032-media-i2c-Add-ov5642-sensor.patch \
file://0033-media-soc-camera-fix-parallel-i-f-in-VIN.patch \
file://0034-media-soc_camera-Fix-VIDIOC_S_SELECTION-ioctl-miscal.patch \
- file://0035-regulator-fixed-probe-after-i2c.patch \
file://0040-arm64-dts-renesas-add-ADAS-boards.patch \
file://0042-arm64-dts-renesas-r8a7795-es1-h3ulcb-disable-eMMC.patch \
file://0043-arm64-dts-renesas-ulcb-use-versaclock-for-du-rgb-and-lvds.patch \