aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAymeric Aillet <aymeric.aillet@iot.bzh>2019-09-20 16:40:28 +0200
committerAymeric Aillet <aymeric.aillet@iot.bzh>2019-10-02 11:15:47 +0200
commit1677edcc93b21c6273e2ba9d40d55fe429306a48 (patch)
treecbfc6d60ead1d528fa88050ecd6123aa35797155
parent763f55fef6fe96027403213b09c8575b1ee0faf6 (diff)
[Community] Optee_os recipe modification
In order to build trusted applications from the official optee sources we need files that weren't built with the current version of the recipe. This modification allow us to build trusted applications in the AGL environment. BUG-AGL: SPEC-2848 Change-Id: Ic34121428abbaf316656519f71d876abfc1f95d5 Signed-off-by: Aymeric Aillet <aymeric.aillet@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index aeea185..e338631 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -50,8 +50,10 @@ do_compile() {
oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y
}
-# do_install() nothing
-do_install[noexec] = "1"
+do_install() {
+ install -d ${D}/usr/share/optee
+ cp -r ${S}/out/arm-plat-${PLATFORM}/export-ta_arm64 ${D}/usr/share/optee
+}
do_deploy() {
# Create deploy folder
@@ -63,3 +65,6 @@ do_deploy() {
install -m 0644 ${S}/out/arm-plat-${PLATFORM}/core/tee.srec ${DEPLOYDIR}/tee-${MACHINE}.srec
}
addtask deploy before do_build after do_compile
+
+FILES_${PN}-staticdev += "${datadir}/optee/export-ta_arm64/lib/*.a"
+FILES_${PN}-dev += "${datadir}/optee/export-ta_arm64"