aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@renesas.com>2019-09-20 11:12:28 +0700
committerKhang Nguyen <khang.nguyen.xw@renesas.com>2019-12-24 15:24:24 +0700
commit26931e33d4aba1bb90e3abce5fdb043b7d989ab7 (patch)
tree4d592a41da8e810825b597a56c1ef07ae6e4cfea
parent54ba967ecfb16553bb555a373212a93690a52ae5 (diff)
rcar-gen3: weston: Remove weston-conf recipe
Since upstream removes weston-conf recipe and move its content to weston-init instead, this also does the same for Renesas specific configurations. This commit also disables intel config of simple-dmabuf-drm option when running meson config of Weston 7.0 to avoid build error. Signed-off-by: Duy Dang <duy.dang.yw@renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Change-Id: Ifba1b3f99cbf1e9cfff5557bf52a9424ad3e2bf7
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend34
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend38
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-init/weston.ini (renamed from meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.ini)0
-rwxr-xr-xmeta-rcar-gen3/recipes-graphics/wayland/weston-init/weston.sh (renamed from meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.sh)0
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend2
5 files changed, 38 insertions, 36 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
deleted file mode 100644
index b76ff81..0000000
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
+++ /dev/null
@@ -1,34 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_rcar-gen3 = " \
- file://weston.ini \
- file://weston.sh \
-"
-
-do_install_append_rcar-gen3() {
- install -d ${D}/${sysconfdir}/xdg/weston
- # install weston.ini as sample settings of gl-renderer
- install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
-
- # Checking for ivi-shell configuration
- # If ivi-shell is enable, we will add its configs to weston.ini
- if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
- sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
- ${D}/${sysconfdir}/xdg/weston/weston.ini
- sed -e '$a\\' \
- -e '$a\[ivi-shell]' \
- -e '$a\ivi-module=ivi-controller.so' \
- -e '$a\ivi-input-module=ivi-input-controller.so' \
- -e '$a\transition-duration=300' \
- -e '$a\cursor-theme=default' \
- -i ${D}/${sysconfdir}/xdg/weston/weston.ini
- fi
-
- # Set XDG_RUNTIME_DIR to /run/user/$UID (e.g. run/user/0)
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN}_append_rcar-gen3 = " \
- ${sysconfdir}/profile.d/weston.sh \
-"
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend
index 58dd3b9..017ca3e 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend
@@ -1,9 +1,43 @@
require include/gles-control.inc
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_rcar-gen3 = " \
+ file://weston.ini \
+ file://weston.sh \
+"
+
do_install_append_rcar-gen3() {
if [ "X${USE_GLES}" = "X1" ]; then
- sed -e "/RequiresMountsFor=\/run/a After=dbus.service multi-user.target" \
+ sed -e "/^After=/s/$/ dbus.service multi-user.target/" \
-e "s/\$OPTARGS/--idle-time=0 \$OPTARGS/" \
- -i ${D}/${systemd_system_unitdir}/weston.service
+ -i ${D}/${systemd_system_unitdir}/weston@.service
+ fi
+
+ install -d ${D}/${sysconfdir}/xdg/weston
+ # install weston.ini as sample settings of gl-renderer
+ install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
+
+ # Checking for ivi-shell configuration
+ # If ivi-shell is enable, we will add its configs to weston.ini
+ if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
+ sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
+ ${D}/${sysconfdir}/xdg/weston/weston.ini
+ sed -e '$a\\' \
+ -e '$a\[ivi-shell]' \
+ -e '$a\ivi-module=ivi-controller.so' \
+ -e '$a\ivi-input-module=ivi-input-controller.so' \
+ -e '$a\transition-duration=300' \
+ -e '$a\cursor-theme=default' \
+ -i ${D}/${sysconfdir}/xdg/weston/weston.ini
fi
+
+ # Set XDG_RUNTIME_DIR to /run/user/$UID (e.g. run/user/0)
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
+
+FILES_${PN}_append_rcar-gen3 = " \
+ ${sysconfdir}/profile.d/weston.sh \
+"
+
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.ini b/meta-rcar-gen3/recipes-graphics/wayland/weston-init/weston.ini
index f31c290..f31c290 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.ini
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-init/weston.ini
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.sh b/meta-rcar-gen3/recipes-graphics/wayland/weston-init/weston.sh
index 33ed8a4..33ed8a4 100755
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.sh
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-init/weston.sh
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
index b87603b..31e0495 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
@@ -2,6 +2,8 @@ require include/gles-control.inc
require include/multimedia-control.inc
PACKAGECONFIG_remove_virtclass-multilib-lib32 = "launch"
+PACKAGECONFIG_CONFARGS_append_rcar-gen3 = " -Dsimple-dmabuf-drm=auto"
+
DEPENDS_append_rcar-gen3 = " \
${@oe.utils.conditional('USE_GLES', '1', ' libgbm', '', d)}"