aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@rvc.renesas.com>2017-04-03 15:22:36 +0700
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-04-19 09:59:42 +0700
commit95cb48ba09bc7e55fd549817e3e26723409e68d5 (patch)
treed6897269d5e9585e4fbf7c54184dfadb51cd1b4a
parent5277b94938805bf3b2a5ceb1efc55e4f7d9a0fd7 (diff)
rcar-gen3: Fix issue downloading from http/https proxyRenesas-Yocto-v2.19.0
This patch corrects the problem of git submodule when network of build environment uses http/https proxy. Change-Id: I5ac7a63da7336f3422231863aa08c5fe69ad54df Signed-off-by: Thao Nguyen <thao.nguyen.yb@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-multimedia/avb-applications/avb-demoapps.bb4
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend4
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend4
3 files changed, 12 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/avb-applications/avb-demoapps.bb b/meta-rcar-gen3/recipes-multimedia/avb-applications/avb-demoapps.bb
index ca9fd9c..5951a4c 100644
--- a/meta-rcar-gen3/recipes-multimedia/avb-applications/avb-demoapps.bb
+++ b/meta-rcar-gen3/recipes-multimedia/avb-applications/avb-demoapps.bb
@@ -20,6 +20,10 @@ includedir = "/usr/local/include"
addtask do_init_submodule after do_unpack before do_patch
do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
cd ${S}
git submodule init
git submodule update
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend
index 9ffb791..88e5126 100644
--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.6.3.bbappend
@@ -14,6 +14,10 @@ S = "${WORKDIR}/git"
addtask do_init_submodule after do_unpack before do_patch
do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
cd ${S}
git submodule init
git submodule update
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend
index 6b37048..39e7208 100644
--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.6.3.bbappend
@@ -20,6 +20,10 @@ EXTRA_OECONF_append = " \
addtask do_init_submodule after do_unpack before do_patch
do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
cd ${S}
git submodule init
git submodule update