aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-07-27 11:53:53 +0700
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-09-15 10:20:15 +0200
commitc0b80e24853650b7d373797305b38cd32a0b33f5 (patch)
treef0f4a4b06b4de8cd31c0c9be3ce791ae2eb7d9e1
parent79cf0b6441af8746e4129e7ae807aa0f6a97e675 (diff)
Revert "rcar-gen3: ppp: Add patches to fix build with 4.8/4.9 kernel headers"slawr/renesas-rcar-gen3_pyro_bsp_2.23
ppp has been updated to fix this issue. This reverts commit 4979e05406c77524cf90b308ce4bf2a72032ee65. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch43
-rw-r--r--meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch44
-rw-r--r--meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend6
3 files changed, 0 insertions, 93 deletions
diff --git a/meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch b/meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch
deleted file mode 100644
index a32f89f..0000000
--- a/meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-commit cd90fd147844a0cfec101f1e2db7a3c59d236621
-Author: Jussi Kukkonen <jussi.kukkonen@intel.com>
-Date: Wed Dec 28 14:11:22 2016 +0200
-
-pppol2tp plugin: Remove unneeded include
-
-The include is not required and will break compile on musl libc with
-
-| In file included from pppol2tp.c:34:0:
-| /usr/include/linux/if.h:97:2: error: expected identifier before numeric constant
-| IFF_LOWER_UP = 1<<16, /* __volatile__ */
-
-Patch originally from Khem Raj.
-
-Upstream-Status: Pending [https://github.com/paulusmack/ppp/issues/73]
-Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
-
-diff --git a/pppd/plugins/pppol2tp/openl2tp.c b/pppd/plugins/pppol2tp/openl2tp.c
-index 9643b96..458316b 100644
---- a/pppd/plugins/pppol2tp/openl2tp.c
-+++ b/pppd/plugins/pppol2tp/openl2tp.c
-@@ -47,7 +47,6 @@
- #include <linux/if_ether.h>
- #include <linux/ppp_defs.h>
- #include <linux/if_ppp.h>
--#include <linux/if_pppox.h>
- #include <linux/if_pppol2tp.h>
-
- #include "l2tp_event.h"
-diff --git a/pppd/plugins/pppol2tp/pppol2tp.c b/pppd/plugins/pppol2tp/pppol2tp.c
-index 0e28606..4f6d98c 100644
---- a/pppd/plugins/pppol2tp/pppol2tp.c
-+++ b/pppd/plugins/pppol2tp/pppol2tp.c
-@@ -46,7 +46,6 @@
- #include <linux/if_ether.h>
- #include <linux/ppp_defs.h>
- #include <linux/if_ppp.h>
--#include <linux/if_pppox.h>
- #include <linux/if_pppol2tp.h>
-
- /* should be added to system's socket.h... */
----
-
diff --git a/meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch b/meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch
deleted file mode 100644
index f77b0de..0000000
--- a/meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 3da19af53e2eee2e77b456cfbb9d633b06656d38 Mon Sep 17 00:00:00 2001
-From: Jackie Huang <jackie.huang@windriver.com>
-Date: Thu, 13 Oct 2016 13:41:43 +0800
-Subject: [PATCH] ppp: fix building with linux-4.8
-
-Fix a build error when using the linux-4.8 headers that results in:
-
-In file included from pppoe.h:87:0,
- from plugin.c:29:
-../usr/include/netinet/in.h:211:8: note: originally defined here
- struct in6_addr
- ^~~~~~~~
-In file included from ../usr/include/linux/if_pppol2tp.h:20:0,
- from ../usr/include/linux/if_pppox.h:26,
- from plugin.c:52:
-../usr/include/linux/in6.h:49:8: error: redefinition of 'struct sockaddr_in6'
- struct sockaddr_in6 {
- ^~~~~~~~~~~~
-
-Upstream-Status: Submitted [1]
-
-[1] https://github.com/paulusmack/ppp/pull/69
-
-Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
----
- pppd/plugins/rp-pppoe/pppoe.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pppd/plugins/rp-pppoe/pppoe.h b/pppd/plugins/rp-pppoe/pppoe.h
-index 9ab2eee..96d2794 100644
---- a/pppd/plugins/rp-pppoe/pppoe.h
-+++ b/pppd/plugins/rp-pppoe/pppoe.h
-@@ -84,7 +84,7 @@ typedef unsigned long UINT32_t;
- #include <linux/if_ether.h>
- #endif
-
--#include <netinet/in.h>
-+#include <linux/in.h>
-
- #ifdef HAVE_NETINET_IF_ETHER_H
- #include <sys/types.h>
---
-2.8.3
-
diff --git a/meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend b/meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend
deleted file mode 100644
index 5aa46fb..0000000
--- a/meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_append = " \
- file://ppp-fix-building-with-linux-4.8.patch \
- file://0001-ppp-Remove-unneeded-include.patch \
-"