aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-08 23:22:34 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-08 23:22:34 +0200
commit5698cf23837e1730f21766bf1b34227b61d20133 (patch)
treed0b7ed6cbfb05ddab504475950cc381533d9e2fa
parent33bb9fed153fd641d434a8edea595dca030f9247 (diff)
Fix RSS-related issues for rcar gen2
For pyro we need to fix a few recipes to work with the recipe specific sysroot feature. Change-Id: I9cc12083675ea2522a1f453f603b034e911d79fd Bug-AGL: SPEC-646 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc7
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend (renamed from meta-rcar-gen2/recipes-graphics/mesa/mesa_12.%.bbappend)0
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/libgbm.bb2
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/wayland-kms_1.4.0.bb2
-rw-r--r--meta-rcar-gen2/recipes-kernel/vspm-module/vspm-kernel-module.bb5
-rw-r--r--meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb4
-rw-r--r--meta-rcar-gen2/recipes-multimedia/vspm-module/vspm-user-module.bb3
7 files changed, 15 insertions, 8 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
index fcf6839..0122f30 100644
--- a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
@@ -76,11 +76,12 @@ SRC_URI_append = " file://0001-Patch-Makefiles-to-use-PKG_CONFIG_SYSROOT_PATH.pa
# autogen will clone common ... how evil
autogennoconf() {
cd ${S}
- ./autogen.sh --noconfigure
+ ./autogen.sh --noconfigure --nocheck
}
do_patch[prefuncs] += "autogennoconf"
-do_patch[depends] += "autoconf-native:do_populate_sysroot"
-do_patch[depends] += "gettext-native:do_populate_sysroot"
+# due to the prefuncs statement, we need the dependencies earlier
+do_unpack[depends] += "autoconf-native:do_populate_sysroot"
+do_unpack[depends] += "gettext-native:do_populate_sysroot"
do_install_prepend() {
export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/sdp/.libs"
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_12.%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend
index cd08da8..cd08da8 100644
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_12.%.bbappend
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/libgbm.bb b/meta-rcar-gen2/recipes-graphics/wayland/libgbm.bb
index 3817fb1..38839c2 100644
--- a/meta-rcar-gen2/recipes-graphics/wayland/libgbm.bb
+++ b/meta-rcar-gen2/recipes-graphics/wayland/libgbm.bb
@@ -14,7 +14,7 @@ SRC_URI_append = " \
S = "${WORKDIR}/git"
COMPATIBLE_MACHINE = "(r8a7790|r8a7791|r8a7793|r8a7794)"
-DEPENDS = "wayland-kms"
+DEPENDS = "wayland-kms systemd"
inherit autotools pkgconfig
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/wayland-kms_1.4.0.bb b/meta-rcar-gen2/recipes-graphics/wayland/wayland-kms_1.4.0.bb
index 91c83b4..53c0b81 100644
--- a/meta-rcar-gen2/recipes-graphics/wayland/wayland-kms_1.4.0.bb
+++ b/meta-rcar-gen2/recipes-graphics/wayland/wayland-kms_1.4.0.bb
@@ -10,7 +10,7 @@ SRC_URI = "git://github.com/thayama/wayland-kms;protocol=git;branch=master"
COMPATIBLE_MACHINE = "(r8a7790|r8a7791|r8a7793|r8a7794)"
S = "${WORKDIR}/git"
-DEPENDS = "libdrm wayland gles-user-module"
+DEPENDS = "libdrm wayland gles-user-module wayland-native"
inherit autotools pkgconfig
diff --git a/meta-rcar-gen2/recipes-kernel/vspm-module/vspm-kernel-module.bb b/meta-rcar-gen2/recipes-kernel/vspm-module/vspm-kernel-module.bb
index 2b47298..7e2fc90 100644
--- a/meta-rcar-gen2/recipes-kernel/vspm-module/vspm-kernel-module.bb
+++ b/meta-rcar-gen2/recipes-kernel/vspm-module/vspm-kernel-module.bb
@@ -21,6 +21,9 @@ do_compile() {
make all ARCH=arm
}
+#
+SYSROOT_DIRS += "/usr/src"
+
do_install() {
# Create destination folder
mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/extra/ ${D}/usr/src/kernel/include
@@ -37,7 +40,7 @@ do_install() {
cp -f ${S}/vspm/drv/Module.symvers ${KERNELSRC}/include/vspm.symvers
# Copy for vspm-user-module
- cp -f ${KERNELSRC}/include/vspm_if.h ${BUILDDIR}/include
+ #cp -f ${KERNELSRC}/include/vspm_if.h ${STAGING_KERNEL_DIR}/include
}
# Append function to clean extract source
diff --git a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
index 635b8b7..f177695 100644
--- a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
+++ b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
@@ -99,8 +99,8 @@ do_configure() {
cd ${S}/UDF_Linux
./autogen.sh
./configure --prefix=${D}${RENESAS_DATADIR}/ --host=arm-linux \
- CFLAGS="-I${BUILDDIR}/include -I${KERNELDIR}/include" \
- LDFLAGS="-L${LIBSHARED}" \
+ CFLAGS="-I${BUILDDIR}/include -I${KERNELDIR}/include -I${RECIPE_SYSROOT}/usr/share/renesas/include/" \
+ LDFLAGS="-L${LIBSHARED} -L${RECIPE_SYSROOT}/usr/share/renesas/lib/" \
OMXR_DEFAULT_CONFIG_FILE_NAME=${RENESAS_DATADIR}/config/omxr_config_base.txt
}
diff --git a/meta-rcar-gen2/recipes-multimedia/vspm-module/vspm-user-module.bb b/meta-rcar-gen2/recipes-multimedia/vspm-module/vspm-user-module.bb
index 079a0d9..2c93cae 100644
--- a/meta-rcar-gen2/recipes-multimedia/vspm-module/vspm-user-module.bb
+++ b/meta-rcar-gen2/recipes-multimedia/vspm-module/vspm-user-module.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://vspm-user.tar.bz2"
S = "${WORKDIR}"
+# workaround for vspm-kernel-module header
+CC += " -I${RECIPE_SYSROOT}/usr/src/kernel/include "
+
do_compile() {
# Build shared library
cd ${S}/vspm/if