summaryrefslogtreecommitdiffstats
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-15 13:18:47 -0500
committerScott Murray <scott.murray@konsulko.com>2019-12-15 13:24:24 -0500
commit6b250497f27c37cae1d005f06158146e47ec8800 (patch)
tree099c8f3c36560959ecb3d6e7c5a603566ad642f3 /app/CMakeLists.txt
parentec96cfc6edfbadd3926374579319af2641aa856f (diff)
Updates to fix building with SDK and remove submodule usageicefish_8.99.4icefish_8.99.3icefish/8.99.4icefish/8.99.38.99.48.99.3
Update the autobuild script and CMake files to work with the SDK, and remove now deprecated usage of the app-templates submodule. Bug-AGL: SPEC-3055 Change-Id: Ib01f46fa510df2614021a8f256ab09fdcff8871a Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 07c60c4..9547426 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -1,5 +1,5 @@
###########################################################################
-# Copyright 2018 Konsulko Group
+# Copyright 2018,2019 Konsulko Group
#
# Author: Scott Murray <scott.murray@konsulko.com>
#
@@ -18,7 +18,10 @@
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(OE_QMAKE_PATH_EXTERNAL_HOST_BINS $ENV{OE_QMAKE_PATH_HOST_BINS})
find_package(Qt5 COMPONENTS Core Gui QuickControls2 WebSockets QuickWidgets REQUIRED)
find_package(PkgConfig REQUIRED)