summaryrefslogtreecommitdiffstats
path: root/test/afb-test/fixtures/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederic Marec <frederic.marec@iot.bzh>2019-05-10 17:59:25 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-05-13 08:19:37 +0000
commitcb6b878f2a09f8b8b9b030a12efe948b3276745d (patch)
tree8e7052ae5ef2b7ca35795d7118129dd7115aaab5 /test/afb-test/fixtures/CMakeLists.txt
parentc412ecf8c08a926c15c26b61e981b162f072a94f (diff)
Add test fixtures to set up environment
Add script to check /etc/platform-info presence Add script to check necessary files Add script to set up environment Add script to set down environment Modify get test Bug-AGL: SPEC-2362 Change-Id: I733cb86cc8c616ffdbfcb88cb96a2a4a5b97e652 Signed-off-by: Frederic Marec <frederic.marec@iot.bzh>
Diffstat (limited to 'test/afb-test/fixtures/CMakeLists.txt')
-rw-r--r--test/afb-test/fixtures/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/test/afb-test/fixtures/CMakeLists.txt b/test/afb-test/fixtures/CMakeLists.txt
new file mode 100644
index 0000000..a8baab9
--- /dev/null
+++ b/test/afb-test/fixtures/CMakeLists.txt
@@ -0,0 +1,30 @@
+###########################################################################
+# Copyright 2018 IoT.bzh
+#
+# author:Frédéric Marec <frederic.marec@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# Platform-info test Fixtures
+##################################################
+PROJECT_TARGET_ADD(data-files)
+
+ file(GLOB DATA_FILES "*.sh" "*.json")
+ add_input_files("${DATA_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "TEST-DATA"
+ OUTPUT_NAME ${TARGET_NAME}
+ )