summaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorLi, Xiaoming <lixm.fnst@cn.fujitsu.com>2020-06-22 11:07:30 +0800
committerLi Xiaoming <lixm.fnst@cn.fujitsu.com>2020-07-21 12:31:15 +0000
commitabb024ffcbf800a51dc7a7c513611141d82b2a3b (patch)
treed527d9ffb743460058ef3f275cd063efcb65a9d8 /binding/CMakeLists.txt
parent0c6f41e5965d0013cd871659c52c9abb1057550c (diff)
The test folder should rest in the root of a package. Bug-AGL: SPEC-2807 Change-Id: I6e44e68f40aaf58d2c59973e6a2413947dcb4eaf Signed-off-by: Li, Xiaoming <lixm.fnst@cn.fujitsu.com>
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt20
1 files changed, 17 insertions, 3 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
index 459773a..0ac597f 100644
--- a/binding/CMakeLists.txt
+++ b/binding/CMakeLists.txt
@@ -1,7 +1,8 @@
###########################################################################
# Copyright 2015, 2016, 2017 IoT.bzh
#
-# author: Romain Forlot <romain.forlot@iot.bzh>
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Romain Forlot <romain.forlot@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -16,7 +17,20 @@
# limitations under the License.
###########################################################################
-CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+# Add target to project dependency list
+PROJECT_TARGET_ADD(afm-poi-binding)
-include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+ # Define project Targets
+ add_library(afm-poi-binding MODULE binding-api.h binding-api.c verbs.cpp)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "lib"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})