aboutsummaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
new file mode 100644
index 0000000..88abfaf
--- /dev/null
+++ b/binding/CMakeLists.txt
@@ -0,0 +1,48 @@
+################################################################################
+# Copyright 2019 Microchip Technology Inc. and its subsidiaries
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+################################################################################
+
+add_subdirectory(amplifier)
+add_subdirectory(slimamp)
+add_subdirectory(microphone)
+add_subdirectory(wrap-unicens)
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(ucs2-ctrl)
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE binding.c)
+
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME} PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR}/amplifier
+ ${CMAKE_CURRENT_SOURCE_DIR}/slimamp
+ ${CMAKE_CURRENT_SOURCE_DIR}/microphone
+ ${CMAKE_CURRENT_SOURCE_DIR}/wrap-unicens
+ )
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ucs-slimamp
+ ucs-amplifier
+ ucs-microphone
+ ucs-wrapper
+ ${link_libraries}
+ )