aboutsummaryrefslogtreecommitdiffstats
path: root/binding/amplifier/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'binding/amplifier/CMakeLists.txt')
-rw-r--r--binding/amplifier/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/binding/amplifier/CMakeLists.txt b/binding/amplifier/CMakeLists.txt
new file mode 100644
index 0000000..744fee6
--- /dev/null
+++ b/binding/amplifier/CMakeLists.txt
@@ -0,0 +1,32 @@
+################################################################################
+# Copyright 2019 Microchip Technology Inc. and its subsidiaries
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+################################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(ucs-amplifier)
+
+# Define targets source files
+ADD_LIBRARY(${TARGET_NAME} STATIC amplifier.c)
+
+ # Expose Library Properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES OUTPUT_NAME amplifier)
+
+ # Library dependencies from PKG_REQUIRED_LIST
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries} m)
+
+ # Define properties to expose when others use this target
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME} PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR}/../wrap-unicens
+ )