aboutsummaryrefslogtreecommitdiffstats
path: root/binding/wrap-unicens/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'binding/wrap-unicens/CMakeLists.txt')
-rw-r--r--binding/wrap-unicens/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/binding/wrap-unicens/CMakeLists.txt b/binding/wrap-unicens/CMakeLists.txt
new file mode 100644
index 0000000..ccd3f16
--- /dev/null
+++ b/binding/wrap-unicens/CMakeLists.txt
@@ -0,0 +1,27 @@
+################################################################################
+# Copyright 2019 Microchip Technology Inc. and its subsidiaries
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+################################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(ucs-wrapper)
+
+# Define targets source files
+ADD_LIBRARY(${TARGET_NAME} STATIC wrap-unicens.c)
+
+ # Expose Library Properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES OUTPUT_NAME wrap-unicens)
+
+ # Library dependencies from PKG_REQUIRED_LIST
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})