summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNaveen Bobbili <nbobbili@amazon.com>2019-02-25 21:00:09 -0800
committerNaveen Bobbili <nbobbili@amazon.com>2019-02-25 21:06:18 -0800
commit533f49cc00b0846c4f2ebd763b86b917f5023cdc (patch)
tree0950a62bc5c75c24712fefb8532ff82a23f1b947 /CMakeLists.txt
parent800ec166dd48283fd7f3035685e6b6a73091552d (diff)
vshl-capabilities:
This API is responsible for brokering capbilities related messages from voiceagents to apps and vice versa. Verbs exposed are navigation/publish navigation/subscribe phonecontrol/publish phonecontrol/subscribe playbackcontroller/publish playbackcontroller/subscribe guiMetadata/publish guiMetadata/subscribe This API exposes publish and subscribe methods for all the speech framework domains/capabilities. For eg. navigation, phonecontrol etc. This API is used by apps and low level voice agent binding to subscribe and publish these capability messages whenever applicable. This specific commit is for vshl-capabilities API. Change-Id: I822c2e8589e39574d707a7c199bea91a686dced7 Signed-off-by: Naveen Bobbili <nbobbili@amazon.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f39acc4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2018 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.5.1)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)