summaryrefslogtreecommitdiffstats
path: root/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/CMakeLists.txt')
-rw-r--r--plugin/CMakeLists.txt42
1 files changed, 6 insertions, 36 deletions
diff --git a/plugin/CMakeLists.txt b/plugin/CMakeLists.txt
index 2672f72..3fd93ec 100644
--- a/plugin/CMakeLists.txt
+++ b/plugin/CMakeLists.txt
@@ -1,13 +1,13 @@
###########################################################################
-# Copyright 2015, 2016, 2017, 2018 IoT.bzh
+# Copyright 2015, 2016, 2017 IoT.bzh
#
-# author: Jonathan Aillet <jonathan.aillet@iot.bzh>
+# author: Fulup Ar Foll <fulup@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
@@ -16,37 +16,7 @@
# limitations under the License.
###########################################################################
-ADD_SUBDIRECTORY(ucs2-vol)
-PROJECT_TARGET_ADD(hal-unicens)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE
- most_unicens.c
- wrap_unicens.c
- wrap_volume.c
- )
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- LABELS "PLUGIN"
- PREFIX ""
- SUFFIX ".ctlso"
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- afb-helpers
- ctl-utilities
- ucs2-volume
- ${link_libraries}
- )
-
- target_include_directories(${TARGET_NAME}
- PRIVATE "${CMAKE_SOURCE_DIR}/app-controller/ctl-lib"
- #PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-controllers"
- #PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-manager"
- #PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-utilities"
- PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/ucs2-vol/inc"
- )
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD()