summaryrefslogtreecommitdiffstats
path: root/plugin/unicens-output/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/unicens-output/CMakeLists.txt')
-rw-r--r--plugin/unicens-output/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/plugin/unicens-output/CMakeLists.txt b/plugin/unicens-output/CMakeLists.txt
new file mode 100644
index 0000000..b6e9977
--- /dev/null
+++ b/plugin/unicens-output/CMakeLists.txt
@@ -0,0 +1,52 @@
+###########################################################################
+# Copyright 2015, 2016, 2017, 2018 IoT.bzh
+#
+# author: Jonathan Aillet <jonathan.aillet@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+ADD_SUBDIRECTORY(ucs2-vol)
+
+PROJECT_TARGET_ADD(hal-unicens-output)
+
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE
+ most_unicens.c
+ wrap_unicens.c
+ wrap_volume.c
+ )
+
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "PLUGIN"
+ PREFIX ""
+ SUFFIX ".ctlso"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-helpers
+ ctl-utilities
+ ucs2-volume
+ ${link_libraries}
+ )
+
+ target_include_directories(${TARGET_NAME}
+ PRIVATE "${CMAKE_SOURCE_DIR}/app-controller/ctl-lib"
+ #PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-controllers"
+ #PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-manager"
+ #PRIVATE "${CMAKE_SOURCE_DIR}/4a-hal/4a-hal-utilities"
+ PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/ucs2-vol/inc"
+ )