summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-10-27 15:41:29 +0300
committerMarius Vlad <marius.vlad@collabora.com>2022-10-27 17:24:29 +0300
commitdcb11eebdba956e567c7421b0511a6e6f0298931 (patch)
treeae5a491184d0a44da24158a8d47eecab00ef3fbb /meson.build
parent4df12ac75fc5b65b7cfbf9d1829c0f780595d43e (diff)
meson.build: Remove all traces of agl-shell-desktop
This patch removes support for agl-shell-desktop. Bug-AGL: SPEC-4503 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I1ad69a4fc4c8ccdc9c659ec1a50526fc9f3a8d81
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build56
1 files changed, 0 insertions, 56 deletions
diff --git a/meson.build b/meson.build
index fa7b1bb..321f130 100644
--- a/meson.build
+++ b/meson.build
@@ -49,67 +49,11 @@ grpc_deps = [
]
-env_modmap = ''
-
-libwayland_dep = dependency('wayland-client')
-agl_compositor_dep = dependency('agl-compositor-0.0.20-protocols')
-
-dep_scanner = dependency('wayland-scanner', native: true)
-prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
-dep_wp = dependency('wayland-protocols', version: '>= 1.18')
-dir_wp_base = dep_wp.get_pkgconfig_variable('pkgdatadir')
-dir_agl_compositor_base = agl_compositor_dep.get_pkgconfig_variable('pkgdatadir')
-
-protocols = [
- { 'name': 'agl-shell-desktop', 'source': 'agl-compositor' },
-]
-
-foreach proto: protocols
- proto_name = proto['name']
- if proto['source'] == 'internal'
- base_file = proto_name
- xml_path = join_paths('protocol', '@0@.xml'.format(base_file))
- elif proto['source'] == 'wp-stable'
- base_file = proto_name
- xml_path = join_paths(dir_wp_base, 'stable', proto_name, '@0@.xml'.format(base_file))
- elif proto['source'] == 'agl-compositor'
- base_file = proto_name
- xml_path = join_paths(dir_agl_compositor_base, '@0@.xml'.format(base_file))
- else
- base_file = '@0@-unstable-@1@'.format(proto_name, proto['version'])
- xml_path = join_paths(dir_wp_base, 'unstable', proto_name, '@0@.xml'.format(base_file))
- endif
-
- foreach output_type: [ 'client-header', 'server-header', 'private-code' ]
- if output_type == 'client-header'
- output_file = '@0@-client-protocol.h'.format(base_file)
- elif output_type == 'server-header'
- output_file = '@0@-server-protocol.h'.format(base_file)
- else
- output_file = '@0@-protocol.c'.format(base_file)
- if dep_scanner.version().version_compare('< 1.14.91')
- output_type = 'code'
- endif
- endif
-
- var_name = output_file.underscorify()
- target = custom_target(
- '@0@ @1@'.format(base_file, output_type),
- command: [ prog_scanner, output_type, '@INPUT@', '@OUTPUT@' ],
- input: xml_path,
- output: output_file,
- )
-
- set_variable(var_name, target)
- endforeach
-endforeach
-
prefix_path = get_option('prefix')
binplugin_dir = join_paths(prefix_path, get_option('bindir'))
common_inc = include_directories('include')
deps_agl_activator = [
- libwayland_dep,
grpc_deps,
]