summaryrefslogtreecommitdiffstats
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-23 14:29:20 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-23 14:29:20 +0900
commite33fb7867a36b803f7ae2a1cb8f1a3b4f9076e08 (patch)
treeef2972d4b72a7a1cc63ac69155574278b2e0be8c /include/CMakeLists.txt
parentf5c14333d2170ae9babed53ea530828569a830ff (diff)
Split libhomescreen from agl-homescreen-service-2017
Split libhomescreen library from agl-homescreen-service-2017. Relative commit: https://gerrit.automotivelinux.org/gerrit/#/c/11413/ Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
new file mode 100644
index 0000000..bb37242
--- /dev/null
+++ b/include/CMakeLists.txt
@@ -0,0 +1,19 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+if(DEFINED CMAKE_INSTALL_INCLUDEDIR)
+ INSTALL(FILES libhomescreen.hpp DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+endif(DEFINED CMAKE_INSTALL_INCLUDEDIR)