aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-23 14:29:20 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-23 14:29:20 +0900
commite33fb7867a36b803f7ae2a1cb8f1a3b4f9076e08 (patch)
treeef2972d4b72a7a1cc63ac69155574278b2e0be8c /src/CMakeLists.txt
parentf5c14333d2170ae9babed53ea530828569a830ff (diff)
Split libhomescreen from agl-homescreen-service-2017
Split libhomescreen library from agl-homescreen-service-2017. Relative commit: https://gerrit.automotivelinux.org/gerrit/#/c/11413/ Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..babf49d
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,48 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+
+cmake_minimum_required(VERSION 3.0)
+
+set(TARGET_LIBHOMESCREEN homescreen)
+add_definitions("-std=c++11")
+
+pkg_check_modules(libhomescreen_depends json-c libafbwsc libsystemd)
+set(libhomescreen_sources libhomescreen.cpp)
+
+include_directories(${LIBHOMESCREEN_INCLUDE_DIR})
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+add_library(${TARGET_LIBHOMESCREEN} SHARED ${libhomescreen_sources})
+target_compile_options(${TARGET_LIBHOMESCREEN} PUBLIC ${libhomescreen_depends_CFLAGS})
+
+if(DEFINED DEBUGMODE)
+ target_compile_options(${TARGET_LIBHOMESCREEN} PRIVATE -g -O0)
+else(DEFINED DEBUGMODE)
+ target_compile_options(${TARGET_LIBHOMESCREEN} PRIVATE -g -O2)
+endif(DEFINED DEBUGMODE)
+
+include_directories(${TARGET_LIBHOMESCREEN} ${libhomescreen_depends_INCLUDE_DIRS})
+target_link_libraries(${TARGET_LIBHOMESCREEN} afbwsc -lpthread ${link_libraries} ${libhomescreen_depends_LIBRARIES})
+set_target_properties(${TARGET_LIBHOMESCREEN}
+ PROPERTIES
+ VERSION 0.1
+)
+
+if(DEFINED CMAKE_INSTALL_LIBDIR)
+ INSTALL(TARGETS ${TARGET_LIBHOMESCREEN}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+endif(DEFINED CMAKE_INSTALL_LIBDIR)