aboutsummaryrefslogtreecommitdiffstats
path: root/tcg/meson.build
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
committerTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
commite02cda008591317b1625707ff8e115a4841aa889 (patch)
treeaee302e3cf8b59ec2d32ec481be3d1afddfc8968 /tcg/meson.build
parentcc668e6b7e0ffd8c9d130513d12053cf5eda1d3b (diff)
Introduce Virtio-loopback epsilon release:
Epsilon release introduces a new compatibility layer which make virtio-loopback design to work with QEMU and rust-vmm vhost-user backend without require any changes. Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com> Change-Id: I52e57563e08a7d0bdc002f8e928ee61ba0c53dd9
Diffstat (limited to 'tcg/meson.build')
-rw-r--r--tcg/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/tcg/meson.build b/tcg/meson.build
new file mode 100644
index 000000000..c4c63b19d
--- /dev/null
+++ b/tcg/meson.build
@@ -0,0 +1,20 @@
+tcg_ss = ss.source_set()
+
+tcg_ss.add(files(
+ 'optimize.c',
+ 'region.c',
+ 'tcg.c',
+ 'tcg-common.c',
+ 'tcg-op.c',
+ 'tcg-op-gvec.c',
+ 'tcg-op-vec.c',
+))
+
+if get_option('tcg_interpreter')
+ libffi = dependency('libffi', version: '>=3.0', required: true,
+ method: 'pkg-config', kwargs: static_kwargs)
+ specific_ss.add(libffi)
+ specific_ss.add(files('tci.c'))
+endif
+
+specific_ss.add_all(when: 'CONFIG_TCG', if_true: tcg_ss)