summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-09-12 11:29:41 +0200
committerMarcus Fritzsch <marcus_fritzsch@mentor.com>2017-09-12 11:29:41 +0200
commitddb822961ddd70d76f911a4580065d69ebf970d9 (patch)
tree8f092e661b852430e591e1e38c1374bf6d559fa4 /src/CMakeLists.txt
parent9fcedd79dd25767658b653ed04a77cf65316b0a5 (diff)
add redraw_fixer, separate controller tool
* Use the existing wayland.hpp/cpp implementation * Listen for visibility and destination_rectangle events * Apply changing values to opacity to "fix" redraw Signed-off-by: Marcus Fritzsch <marcus_fritzsch@mentor.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt32
1 files changed, 31 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 953b59a..f83aae2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -27,7 +27,22 @@ add_library(winman MODULE
afb_binding_api.cpp
result.hpp
afb_binding_api.hpp
- afb_binding_glue.inl layers.cpp layers.hpp controller_hooks.hpp config.cpp config.hpp policy.hpp)
+ afb_binding_glue.inl
+ layers.cpp
+ layers.hpp
+ controller_hooks.hpp
+ config.cpp
+ config.hpp
+ policy.hpp)
+
+add_executable(redraw_fixer
+ redraw_fixer.cpp
+ ${IVI_CON_PROTO}
+ wayland.cpp
+ wayland.hpp
+ controller_hooks.hpp
+ util.cpp
+ util.hpp)
target_include_directories(winman
PRIVATE
@@ -36,6 +51,10 @@ target_include_directories(winman
../include
../src)
+target_link_libraries(redraw_fixer
+ PRIVATE
+ ${WLC_LIBRARIES})
+
target_link_libraries(winman
PRIVATE
${AFB_LIBRARIES}
@@ -50,10 +69,18 @@ target_compile_definitions(winman
WINMAN_VERSION_STRING="${PACKAGE_VERSION}"
_GNU_SOURCE) # XXX should I define this here?!
+target_compile_definitions(redraw_fixer
+ PRIVATE
+ DO_NOT_USE_AFB # override log* AFB macros
+ _GNU_SOURCE)
+
if(NOT ${CMAKE_BUILD_TYPE} STREQUAL "Release")
target_compile_definitions(winman
PRIVATE
_GLIBCXX_DEBUG)
+ target_compile_definitions(redraw_fixer
+ PRIVATE
+ _GLIBCXX_DEBUG)
endif()
target_compile_options(winman
@@ -78,6 +105,9 @@ if (LINK_LIBCXX)
set_target_properties(winman
PROPERTIES
LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/../export.map -lc++")
+ set_target_properties(redraw_fixer
+ PROPERTIES
+ LINK_FLAGS "-lc++")
endif()
if (NOT ${SANITIZER_MODE} STREQUAL "none" AND NOT ${SANITIZER_MODE} STREQUAL "")