summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Shamanin <andrei.shamanin@orioninc.com>2020-10-26 15:22:32 +0300
committerAndrey Shamanin <andrei.shamanin@orioninc.com>2020-10-26 15:28:16 +0300
commit1871597cb1e4b18f5cc4a1567b8edb3eefc8ee49 (patch)
treecc43b5684360059342761043fa202f96b4d8fb94
parent5d7e6770b1248513330f85acbbbe14c7f9d854ca (diff)
Add libcloudproxy to demo image and crosssdk as feature
Bug-AGL: SPEC-3667 Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com> Change-Id: I9b14ebd1e3c3c647c8c2b90f02886b397e9a81bc
-rw-r--r--recipes-apis/agl-service-cloudproxy/libcloudproxy_git.bb19
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb2
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes-apis/agl-service-cloudproxy/libcloudproxy_git.bb b/recipes-apis/agl-service-cloudproxy/libcloudproxy_git.bb
new file mode 100644
index 00000000..dddfcc8d
--- /dev/null
+++ b/recipes-apis/agl-service-cloudproxy/libcloudproxy_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "AGL Client Cloud Proxy Library"
+DESCRIPTION = "libcloudproxy"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libcloudproxy;protocol=https"
+SRCREV = "2d66933b9bf25af66696b097283109c8a6e87151"
+
+S = "${WORKDIR}/git"
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
index 1c375705..489916b5 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
@@ -26,5 +26,5 @@ RDEPENDS_${PN} += "\
agl-service-unicens \
agl-service-unicens-controller \
agl-service-weather \
- ${@bb.utils.contains('AGL_CLOUDPROXY_WANTED','1', 'agl-service-cloudproxy', '', d)} \
+ ${@bb.utils.contains('AGL_CLOUDPROXY_WANTED','1', 'agl-service-cloudproxy libcloudproxy', '', d)} \
"