summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-21 18:32:35 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-22 12:26:00 +0000
commit6dc0e32fbda2c122a2b59630d774dc4ef1a49619 (patch)
treefe12e1df442a0606dfc2c5584eaaf5f6be8afb7f
parente9aff80fda75723360d070793e645a8db541b8bf (diff)
KVM demo updates
Changes: - Fix native-shell-client systemd unit to work with the changes made for SPEC-4714 (separate agl-compositor systemd unit, running as agl-driver). - Update agl-qemu-runner.sh for the SPEC-4714 changes. - Tweak cluster guest configuration to use just 2 cores and 1 GB of memory to free up resources for the host. - Add inverted psplash configuration that is pulled in for the KVM demo image when building with agl-demo-preload. This matches the inverted screen in the demo hardware. Bug-AGL: SPEC-4974 Change-Id: Ie57a3550c8c8b12fd64ee14a9f1fbf4a4c40da32 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29460 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account
-rw-r--r--recipes-config/qemu-config/files/agl-cluster-demo-platform-flutter.conf4
-rw-r--r--recipes-core/psplash/files/psplash-inverted.conf2
-rw-r--r--recipes-core/psplash/psplash-inverted-config.bb20
-rw-r--r--recipes-core/udev/output-udev-conf/91-output.rules4
-rw-r--r--recipes-demo/native-shell-client/files/native-shell-client.service7
-rwxr-xr-xrecipes-extended/agl-qemu-runner/files/agl-qemu-runner.sh2
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb2
7 files changed, 33 insertions, 8 deletions
diff --git a/recipes-config/qemu-config/files/agl-cluster-demo-platform-flutter.conf b/recipes-config/qemu-config/files/agl-cluster-demo-platform-flutter.conf
index 1ecefc47..99d1f10c 100644
--- a/recipes-config/qemu-config/files/agl-cluster-demo-platform-flutter.conf
+++ b/recipes-config/qemu-config/files/agl-cluster-demo-platform-flutter.conf
@@ -1,5 +1,5 @@
QEMU_TASKSET_CPUS="4-7"
-QEMU_SMP_OPT="-smp 4"
-QEMU_MEM_OPT="-m 2G"
+QEMU_SMP_OPT="-smp 2"
+QEMU_MEM_OPT="-m 1G"
QEMU_NET_OPT="-netdev bridge,br=vmnet0,id=net0 -device virtio-net-device,mac=52:54:00:12:00:03,netdev=net0"
QEMU_KERNEL_CMDLINE_APPEND="root=/dev/vda rw mem=2048M video=Virtual-1:1920x1080"
diff --git a/recipes-core/psplash/files/psplash-inverted.conf b/recipes-core/psplash/files/psplash-inverted.conf
new file mode 100644
index 00000000..440db891
--- /dev/null
+++ b/recipes-core/psplash/files/psplash-inverted.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=PSPLASH_ANGLE_ARGS='--angle 180'
diff --git a/recipes-core/psplash/psplash-inverted-config.bb b/recipes-core/psplash/psplash-inverted-config.bb
new file mode 100644
index 00000000..f11b255d
--- /dev/null
+++ b/recipes-core/psplash/psplash-inverted-config.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Systemd unit override for psplash inverted mode for the AGL Demonstrator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://psplash-inverted.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "psplash"
diff --git a/recipes-core/udev/output-udev-conf/91-output.rules b/recipes-core/udev/output-udev-conf/91-output.rules
index 89af4645..9b09a7ca 100644
--- a/recipes-core/udev/output-udev-conf/91-output.rules
+++ b/recipes-core/udev/output-udev-conf/91-output.rules
@@ -1,6 +1,6 @@
# Associate all input devices with the first display
#
# NOTE: Can be more selective with something like:
-# SUBSYSTEM=="input", ATTRS{idVendor}=="*", ATTRS{idProduct}=="004a", OWNER="display", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
+# SUBSYSTEM=="input", ATTRS{idVendor}=="*", ATTRS{idProduct}=="004a", OWNER="agl-driver", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
#
-SUBSYSTEM=="input", OWNER="display", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
+SUBSYSTEM=="input", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
diff --git a/recipes-demo/native-shell-client/files/native-shell-client.service b/recipes-demo/native-shell-client/files/native-shell-client.service
index d7a2fe68..eff62011 100644
--- a/recipes-demo/native-shell-client/files/native-shell-client.service
+++ b/recipes-demo/native-shell-client/files/native-shell-client.service
@@ -1,10 +1,11 @@
[Unit]
-Requires=weston.service
-After=weston.service
+Requires=agl-compositor.service
+After=agl-compositor.service
[Service]
Type=simple
-Environment=XDG_RUNTIME_DIR=/run/user/200
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001
ExecStart=/usr/bin/native-shell-client
Restart=on-failure
diff --git a/recipes-extended/agl-qemu-runner/files/agl-qemu-runner.sh b/recipes-extended/agl-qemu-runner/files/agl-qemu-runner.sh
index d050bdbf..ab3a02c9 100755
--- a/recipes-extended/agl-qemu-runner/files/agl-qemu-runner.sh
+++ b/recipes-extended/agl-qemu-runner/files/agl-qemu-runner.sh
@@ -37,7 +37,7 @@ if [ -n "$QEMU_TASKSET_CPUS" ]; then
fi
export SDL_VIDEODRIVER=wayland
-export XDG_RUNTIME_DIR=/run/user/200
+export XDG_RUNTIME_DIR=/run/user/1001
# The following may be needed if the socket is not wayland-0, as SDL
# seems to lack detection logic for that case.
#export WAYLAND_DISPLAY=wayland-1
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index 6cdafb64..a4620fc9 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -14,8 +14,10 @@ IMAGE_KUKSA_PACKAGES = " \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-kuksa-val-databroker-devel' , '', d)} \
"
+
# generic
IMAGE_INSTALL += "\
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
\
packagegroup-agl-networking \