summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-12-09 18:13:44 +0100
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-12-09 18:25:54 +0100
commita43ef70aa27fe0c7cf7b83dae5895b7e2cd6559e (patch)
tree1bfc751a207e3aab7d85a3624f4f2e4c7642fa01
parent75ae0c88da4a0e25936aa3e8ccee39ae6a5b0cb0 (diff)
agl-demo-platform-html5: Create new image
Add new image called agl-demo-platform-html5, which contains the web application runtime and HTML demo apps. Currently, only the HTML launcher is available, but more will be published. Bug-AGL: SPEC-2322 Change-Id: I4628d1be18f64b7eaf4a0882a13bd1d680426516 Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
-rw-r--r--recipes-platform/images/agl-demo-platform-html5.bb14
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb26
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-demo-platform-html5.bb b/recipes-platform/images/agl-demo-platform-html5.bb
new file mode 100644
index 00000000..2d3490fd
--- /dev/null
+++ b/recipes-platform/images/agl-demo-platform-html5.bb
@@ -0,0 +1,14 @@
+SUMMARY = "DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Contains the web runtime and sample web apps"
+
+require agl-demo-platform.inc
+
+LICENSE = "MIT"
+
+IMAGE_FEATURES_append = " \
+ "
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL_append = " \
+ packagegroup-agl-demo-platform-html5 \
+ "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
new file mode 100644
index 00000000..8352b727
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -0,0 +1,26 @@
+SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-demo-platform-html5 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-image-ivi \
+ packagegroup-agl-profile-graphical-html5 \
+ packagegroup-agl-demo \
+ "
+
+AGL_APPS = " \
+ html5-launcher \
+ "
+
+RDEPENDS_${PN}_append = " \
+ ${AGL_APPS} \
+ "