summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-05-02 20:22:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-13 12:08:08 +0000
commitafed300f173dea8fe45bfde20f9c20d7c23658a4 (patch)
tree369fb753d0360e4ac2ea360131f1c1304f2c8763
parentd38602afcce435a102ecb0aa0c40231c266d8ddf (diff)
chromium, html5-*: adapt to kirkstone
Adapt the recipes to the changes required by Yocto kirkstone: * Explicit python2 dependency. * Replace _ with : as separator in variables. * Explicit pkgconfig dependency. * Assume always upstream ozone wayland. chromium91: 2c7cb69495..d052051b3b d052051b3b [op][ups][build] Fix with more recent libstdc++ in kirkstone deb1439137 [op][ups][build] Fix breakpad build with kirkstone glibc. e6ee1dd0d0 [op][ups][build] Fix abseil-cpp build with glibc in kirkstone wam: 692f706..31840bc 31840bc [op][w_upsable] IWYU: std::string used in LogManagerConsole 15ce17e [op][n_upsable][build] IWYU: std::numeric_limit used in WebPageBlink missing include. 848565d fixup! [op][agl] New QtLess AGL port html5-homescreen: 5c9e060..fc0ffa4 fc0ffa4 Update to recent dependencies a42b304 Launch background after launcher. html5-launcher: cb6b66c..1283e3b 1283e3b Update dependencies. html5-background: 7b79640..e91be22 e91be22 Update to recent dependencies. html5-hvac: e64d69b..6abbe87 6abbe87 Update to recent dependencies. Bug-AGL: SPEC-4261 Change-Id: I48581a57df3ff22d8aaab2334e4f9b4127a6d427 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
-rw-r--r--recipes-demo/html5-background/html5-background_git.bb8
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb10
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb6
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb10
-rw-r--r--recipes-wam/chromium/chromium.inc9
-rw-r--r--recipes-wam/chromium/chromium_git.bb6
-rw-r--r--recipes-wam/wam/wam_git.bb4
7 files changed, 29 insertions, 24 deletions
diff --git a/recipes-demo/html5-background/html5-background_git.bb b/recipes-demo/html5-background/html5-background_git.bb
index 792b04a8..24888fcc 100644
--- a/recipes-demo/html5-background/html5-background_git.bb
+++ b/recipes-demo/html5-background/html5-background_git.bb
@@ -12,7 +12,9 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
file://webapps-html5-background.desktop \
"
-SRCREV = "7b796408f4ee1ca1b92a02445513d939079af46e"
+SRCREV = "e91be225127ddea6be3ddae5cb35e88c2f0aafb8"
+
+inherit pythonnative
DEPENDS = "nodejs-native"
@@ -33,9 +35,9 @@ do_install() {
install ${WORKDIR}/webapps-html5-background.desktop ${D}${APPLICATIONS_DIR}
}
-FILES_${PN} = " \
+FILES:${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
"
-RCONFLICTS_${PN} = "homescreen"
+RCONFLICTS:${PN} = "homescreen"
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 058e921e..cff6d473 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -12,7 +12,9 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
file://homescreen.service \
"
-SRCREV = "5c9e060c508ab5ea49241d3a88f86075d6dc39cf"
+SRCREV = "fc0ffa4c45d3a6ec6ad8cc9b939ef6c9dd2e7eaf"
+
+inherit pythonnative
DEPENDS = "nodejs-native"
@@ -33,10 +35,10 @@ do_install() {
ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
}
-FILES_${PN} = " \
+FILES:${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${systemd_user_unitdir} \
"
-RCONFLICTS_${PN} = "homescreen"
-RDEPENDS_${PN} = "applaunchd html5-background"
+RCONFLICTS:${PN} = "homescreen"
+RDEPENDS:${PN} = "applaunchd html5-background"
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index f0106dba..83b67451 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -12,7 +12,9 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
file://webapps-hvac.desktop \
"
-SRCREV = "e64d69bdad0bb302900ec631b54ad6b6d6dcbacd"
+SRCREV = "6abbe876aee09b225af9329e28b4fa2cc4d4c220"
+
+inherit pythonnative
DEPENDS = "nodejs-native"
@@ -33,7 +35,7 @@ do_install() {
install ${WORKDIR}/webapps-hvac.desktop ${D}${APPLICATIONS_DIR}
}
-FILES_${PN} = " \
+FILES:${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
"
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 52d7077d..59087006 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -12,7 +12,9 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
file://launcher.desktop \
"
-SRCREV = "cb6b66c3bd94a6ab18cad3ad87c827d4f7e623e9"
+SRCREV = "1283e3bddd4655be0d5208fbbcd9535f8f1ff0f6"
+
+inherit pythonnative
DEPENDS = "nodejs-native"
@@ -33,10 +35,10 @@ do_install() {
install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
}
-FILES_${PN} = " \
+FILES:${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
"
-RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd"
+RCONFLICTS:${PN} = "launcher"
+RDEPENDS:${PN} = "applaunchd"
diff --git a/recipes-wam/chromium/chromium.inc b/recipes-wam/chromium/chromium.inc
index d2c9e906..17e46f46 100644
--- a/recipes-wam/chromium/chromium.inc
+++ b/recipes-wam/chromium/chromium.inc
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "\
require gn-utils.inc
-inherit gettext qemu pythonnative
+inherit gettext qemu pythonnative pkgconfig
DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk at-spi2-atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native curl"
@@ -42,8 +42,6 @@ TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
# Skip do_install:append of webos_system_bus. It is not compatible with this component.
WEBOS_SYSTEM_BUS_FILES_LOCATION = "${S}/files/sysbus"
-PACKAGECONFIG ?= "use-upstream-wayland"
-
PACKAGECONFIG[lttng] = "use_lttng=true,use_lttng=false,lttng-ust,lttng-tools lttng-modules babeltrace"
# Chromium can use v4l2 device for hardware accelerated video decoding on such boards as Renesas R-car M3, for example.
@@ -51,11 +49,6 @@ PACKAGECONFIG[lttng] = "use_lttng=true,use_lttng=false,lttng-ust,lttng-tools ltt
# See https://github.com/igel-oss/meta-browser-hwdecode/tree/igalia-chromium71.
PACKAGECONFIG[use-linux-v4l2] = "use_v4l2_codec=true use_v4lplugin=true use_linux_v4l2_only=true"
-PACKAGECONFIG[use-upstream-wayland] = " \
- ozone_platform_wayland_external=false ozone_platform_wayland=true, \
- ozone_platform_wayland_external=true ozone_platform_wayland=false \
-"
-
# Options to enable debug build. Add this PACKAGECONFIG to local.conf
# to enable debug build. By default debug is completely disabled to
# speed up build
diff --git a/recipes-wam/chromium/chromium_git.bb b/recipes-wam/chromium/chromium_git.bb
index 6e83a5bb..39a216d4 100644
--- a/recipes-wam/chromium/chromium_git.bb
+++ b/recipes-wam/chromium/chromium_git.bb
@@ -8,7 +8,7 @@ SRC_URI = "\
# Needed by catapult
DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
-SRCREV_chromium91 = "2c7cb6949542f7e16b2ffc64b4300ccc4212392b"
+SRCREV_chromium91 = "d052051b3b8696183322f0d21c911dbbf207a8ab"
SRCREV_v8 = "b958ec542dcb086f422a1216a959be38a4cc0339"
CHROMIUM_VERSION = "91.0.4472.114"
@@ -63,6 +63,10 @@ GN_ARGS += "\
"
GN_ARGS:append = " \
+ ozone_platform_wayland_external=false \
+ ozone_platform_wayland=true \
+ use_system_libwayland=true \
+ use_system_wayland_scanner=false \
use_system_minigbm=false \
use_wayland_gbm=false \
"
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index a819d6c7..0c10fed9 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -3,7 +3,7 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-inherit cmake
+inherit cmake pkgconfig
DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native libxml2"
@@ -30,7 +30,7 @@ SRC_URI = "\
file://WebAppMgr.env \
"
S = "${WORKDIR}/git"
-SRCREV = "692f706b8794b093035915bc401576c55a6e03fc"
+SRCREV = "31840bc2867fe7ad8a07bd0a4cbd2dc135a05fb2"
PV = "ose57.agl"