summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-04-02 12:45:47 -0400
committerScott Murray <scott.murray@konsulko.com>2020-04-21 13:04:39 -0400
commitb40821b62d9b3e35d61f735d7e37636cc1968d69 (patch)
tree74d8321b76052f2ec66fcb295112cb6842a842dc
parent2995a0b9adb6c0a48376a1f4f7375d2ca932fa8b (diff)
agl-demo-platform-crosssdk: remove Chromium specific bits from SDK
The gn tool recipe is not usable on dunfell due to python2 dependencies, and the current AGL solution for web applications does not require building Chromium with the SDK, so remove the recipe and the packages explicitly added for Chromium to cut down on the SDK size and build time. Bug-AGL: SPEC-3302 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I7e99f2c7711d2fad9d7608a734a2d96f2cb52e48
-rw-r--r--recipes-devtools/gn/gn.inc21
-rw-r--r--recipes-devtools/gn/gn_66.0.3340.0.r534306.bb8
-rwxr-xr-xrecipes-platform/images/agl-demo-platform-crosssdk.bb31
3 files changed, 0 insertions, 60 deletions
diff --git a/recipes-devtools/gn/gn.inc b/recipes-devtools/gn/gn.inc
deleted file mode 100644
index 2728bc1e..00000000
--- a/recipes-devtools/gn/gn.inc
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "Meta-build system from Google"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d"
-
-DEPENDS = "python-native ninja-native"
-
-SRC_URI = "http://gsdview.appspot.com/chromium-browser-official/chromium-${PV}.tar.xz"
-
-S ?= "${WORKDIR}/chromium-${PV}"
-
-do_compile () {
- cd ${S}/tools/gn
- ./bootstrap/bootstrap.py -s
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 out/Release/gn ${D}${bindir}/gn
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/gn/gn_66.0.3340.0.r534306.bb b/recipes-devtools/gn/gn_66.0.3340.0.r534306.bb
deleted file mode 100644
index d3959f23..00000000
--- a/recipes-devtools/gn/gn_66.0.3340.0.r534306.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require gn.inc
-
-S = "${WORKDIR}/chromium-ozone-wayland-dev-${PV}.igalia.1"
-
-SRC_URI = "https://tmp.igalia.com/chromium-tarballs/chromium-ozone-wayland-dev-${PV}.igalia.1.tar.xz"
-
-SRC_URI[md5sum] = "f418f4df5261cfdcf39e7901924876a2"
-SRC_URI[sha256sum] = "2679c89f09394bf2df86a090958a599303562746ce9296b07c263eb16f8d9148"
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index a814b694..5bb0dc06 100755
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -18,37 +18,6 @@ inherit populate_sdk populate_sdk_qt5
# can failed (randomly).
addtask do_populate_sdk after do_rootfs
-# native tools to support Chromium build inside SDK (SPEC-942)
-TOOLCHAIN_HOST_TASK += " \
- nativesdk-gn \
- nativesdk-ninja \
- nativesdk-gperf \
- nativesdk-zlib \
- nativesdk-xz \
- nativesdk-nspr-dev \
- nativesdk-nss-dev \
- nativesdk-lua \
- "
-
-# required dependencies for Chromium build inside SDK (SPEC-942)
-TOOLCHAIN_TARGET_TASK += " \
- pciutils-dev \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
- cairo-dev \
- nss-dev \
- cups-dev \
- gconf-dev \
- libexif-dev \
- pango-dev \
- libdrm-dev \
- lua-dev \
- lua-staticdev \
- libafb-helpers-staticdev \
- libafb-helpers-qt-staticdev \
- libappcontroller-staticdev \
- ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
- "
-
# Add wayland-scanner to SDK (SPEC-945)
# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
# wayland-scanner is in nativesdk-wayland-dev !