summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-03-02 15:34:27 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-03-09 10:17:33 +0000
commitdb3f2c9ac955d1bf8fd9216ddf4d29b07d98c5b3 (patch)
treeafb4fa4e5586a2c4255dcfb0c216bdb5fbca9818
parent18e861fc0648fe3739d898c0e1b659bedbf569b8 (diff)
packagegroup-agl-demo-platform: fix POI API key preloading
Fix missing switch from DISTRO_FEATURES to AGL_FEATURES in the definition of DEMO_PRELOAD. Also remove the now unused variables for the old navigation app as cleanup. Bug-AGL: SPEC-3833 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I39b4d49c0a213f162657f0086b21b81eb0524ab8
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index c506d0a2..72e5d7a6 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -63,13 +63,8 @@ DEMO_UNIT_CONF ?= ""
# I2C devices for RTC and HVAC LED support.
DEMO_UNIT_CONF += " demo-i2c-udev-conf "
-# Preload poi API key for demo if requested, and potentially maps for older
-# navigation application if it is configured.
-DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
-
# Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
RDEPENDS_${PN}_append = " \
weston-ini-conf \