summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-11-09 09:38:31 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-11 10:38:35 +0000
commite422e5cb73311fd0807b40d8a1fcac53cac7d6eb (patch)
tree5df684bbe5163451c1ecd7be874959f4f7653b89
parent2a1c53a8a152b5744b631278f52264be13f316f1 (diff)
Add PROVIDES into libhomescreen bb files
Restore libhomescreen-old.inc to libhomescreen_git.bb, but use fix SRCREV. Change libhomescreen-2017.inc to libhomescreen-2017_git.bb. Add PROVIDES into bb files for switch libhomescreen. These is another commit in meta-agl-devel set PREFERRED_PROVIDER. Related commit: https://gerrit.automotivelinux.org/gerrit/#/c/11761/ Change-Id: I2eadc3c703f220f286e8ffa6b52276b792fc0729 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb (renamed from recipes-demo-hmi/libhomescreen/libhomescreen-2017.inc)9
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-old.inc58
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen_git.bb59
3 files changed, 67 insertions, 59 deletions
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017.inc b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
index f8432bd0..918d2ec0 100644
--- a/recipes-demo-hmi/libhomescreen/libhomescreen-2017.inc
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
@@ -1,3 +1,11 @@
+SUMMARY = "AGL Home Screen Library"
+DESCRIPTION = "libhomescreen"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = "af-binder json-c"
@@ -9,3 +17,4 @@ SRCREV = "390902a6b002c6af183c939749fdebfcc4b3e839"
S = "${WORKDIR}/git"
RDEPENDS_${PN} = "agl-service-homescreen-2017"
+PROVIDES += "virtual/libhomescreen"
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc b/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
deleted file mode 100644
index 4ec2860e..00000000
--- a/recipes-demo-hmi/libhomescreen/libhomescreen-old.inc
+++ /dev/null
@@ -1,58 +0,0 @@
-LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS += " glib-2.0 "
-
-inherit qmake5 pkgconfig
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
- file://homescreen.pc.in"
-SRCREV = "f5c14333d2170ae9babed53ea530828569a830ff"
-S = "${WORKDIR}/git/"
-
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
-
-do_install() {
- install -d ${D}/usr/AGL/${PN}
- install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
-
- install -d ${D}${libdir}
- install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
- ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
- ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
- ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
-
-# kooltux: still some problem with paths inside .pc file
-# error at build time:
-# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
-#
- install -d ${D}${libdir}/pkgconfig
- install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
- sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
- sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
- sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
-
- install -d ${D}${includedir}
- install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
-}
-
-PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
-
-FILES_${PN} = "\
- ${libdir}/libhomescreen.so.* \
-"
-FILES_${PN}-dev = "\
- ${includedir}/libhomescreen.hpp \
- ${libdir}/libhomescreen.so \
- ${libdir}/pkgconfig/homescreen.pc \
-"
-FILES_${PN}-dbg += "\
- ${libdir}/.debug/libhomescreen.so.* \
-"
-
-FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
-FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
-
-
-RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
-
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
index b39becf4..b71b5b41 100644
--- a/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen_git.bb
@@ -6,4 +6,61 @@ SECTION = "libs"
BBCLASSEXTEND = " nativesdk"
-require ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', 'libhomescreen-2017.inc', 'libhomescreen-old.inc', d)}
+LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS += " glib-2.0 "
+
+inherit qmake5 pkgconfig
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://homescreen.pc.in"
+SRCREV = "f5c14333d2170ae9babed53ea530828569a830ff"
+S = "${WORKDIR}/git/"
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+do_install() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
+
+ install -d ${D}${libdir}
+ install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
+ ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
+ ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
+ ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
+
+# kooltux: still some problem with paths inside .pc file
+# error at build time:
+# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
+#
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
+ sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
+
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
+}
+
+PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
+
+FILES_${PN} = "\
+ ${libdir}/libhomescreen.so.* \
+"
+FILES_${PN}-dev = "\
+ ${includedir}/libhomescreen.hpp \
+ ${libdir}/libhomescreen.so \
+ ${libdir}/pkgconfig/homescreen.pc \
+"
+FILES_${PN}-dbg += "\
+ ${libdir}/.debug/libhomescreen.so.* \
+"
+
+FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
+FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
+
+
+RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
+PROVIDES += "virtual/libhomescreen"