summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-11-15 00:17:42 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-14 16:15:39 +0000
commite96aae7124dff2e42ebdd7eea6415817071b7831 (patch)
treeda11404f6faa59c152975d56b0e49799437dcf54
parentf2f5947688849550a7aea5db3469994455f4f73e (diff)
Update app DEPENDS for new HMI framework
Add virtual/libhomescreen and qlibwindowmanager as DEPENDS in the recipes of apps that have been updated to use the new HMI framework. Change-Id: Ic5bcceaa4273612d0eaa7d1762177b4a1077ddfb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/dashboard/dashboard_git.bb2
-rw-r--r--recipes-demo-hmi/hvac/hvac_git.bb2
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb11
-rw-r--r--recipes-demo-hmi/mixer/mixer_git.bb10
-rw-r--r--recipes-demo-hmi/phone/phone_git.bb7
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb1
-rw-r--r--recipes-demo-hmi/settings/settings_git.bb1
7 files changed, 25 insertions, 9 deletions
diff --git a/recipes-demo-hmi/dashboard/dashboard_git.bb b/recipes-demo-hmi/dashboard/dashboard_git.bb
index 5d02ea25..795e9e12 100644
--- a/recipes-demo-hmi/dashboard/dashboard_git.bb
+++ b/recipes-demo-hmi/dashboard/dashboard_git.bb
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2"
+DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/hvac/hvac_git.bb b/recipes-demo-hmi/hvac/hvac_git.bb
index beaaafaa..d36696bf 100644
--- a/recipes-demo-hmi/hvac/hvac_git.bb
+++ b/recipes-demo-hmi/hvac/hvac_git.bb
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2"
+DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
index 8a7fd620..e99eb5bd 100644
--- a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -12,10 +12,15 @@ SRCREV = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit qmake5 aglwgt
-
# build-time dependencies
-DEPENDS += "sqlite3 qtquickcontrols2 qtmultimedia"
+DEPENDS += "sqlite3 \
+ qtquickcontrols2 \
+ qtmultimedia \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
RDEPENDS_${PN} += "qtmultimedia \
qtmultimedia-qmlplugins \
diff --git a/recipes-demo-hmi/mixer/mixer_git.bb b/recipes-demo-hmi/mixer/mixer_git.bb
index 638dae53..bdbc8db6 100644
--- a/recipes-demo-hmi/mixer/mixer_git.bb
+++ b/recipes-demo-hmi/mixer/mixer_git.bb
@@ -12,7 +12,11 @@ SRCREV = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit qmake5 aglwgt
-
# build-time dependencies
-DEPENDS += "qtquickcontrols2 pulseaudio"
+DEPENDS += "qtquickcontrols2 \
+ pulseaudio \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/phone/phone_git.bb b/recipes-demo-hmi/phone/phone_git.bb
index 6dccd65a..fe91d3f4 100644
--- a/recipes-demo-hmi/phone/phone_git.bb
+++ b/recipes-demo-hmi/phone/phone_git.bb
@@ -13,6 +13,11 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 homescreen libqtappfw qtmultimedia"
+DEPENDS += "qtquickcontrols2 \
+ qtmultimedia \
+ libqtappfw \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
index 5b599de8..8563b018 100644
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -19,6 +19,7 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS = "qtquickcontrols2 rtl-sdr pulseaudio"
+DEPENDS += "virtual/libhomescreen qlibwindowmanager"
inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/settings/settings_git.bb b/recipes-demo-hmi/settings/settings_git.bb
index 28eee069..e36f0bc8 100644
--- a/recipes-demo-hmi/settings/settings_git.bb
+++ b/recipes-demo-hmi/settings/settings_git.bb
@@ -14,6 +14,7 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2"
+DEPENDS += "virtual/libhomescreen qlibwindowmanager"
# runtime dependencies
RDEPENDS_${PN} += " \