summaryrefslogtreecommitdiffstats
path: root/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb')
-rw-r--r--recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb b/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
new file mode 100644
index 00000000..e4dccbf3
--- /dev/null
+++ b/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "HVAC Service Binding Configuration"
+DESCRIPTION = "AGL HVAC Service Binding Configuration"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
+}
+
+do_install_append_ulcb() {
+ sed -i -e "s#vcan0#sllin0#g" ${D}${sysconfdir}/hvac.json
+}
+