summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/ondemandnavi-config_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/navigation/ondemandnavi-config_1.0.bb')
-rw-r--r--recipes-demo/navigation/ondemandnavi-config_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-demo/navigation/ondemandnavi-config_1.0.bb b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
new file mode 100644
index 00000000..212971f2
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL Reference On Demand Navigation application config."
+DESCRIPTION = "Config file for on-demand navigation app."
+HOMEPAGE = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+SECTION = "apps"
+LICENSE = "Proprietary"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+SRC_URI = "file://naviconfig.ini \
+ "
+
+inherit allarch
+
+MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
+ sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
+}