summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/poiapp-api-key_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/navigation/poiapp-api-key_1.0.bb')
-rw-r--r--recipes-demo/navigation/poiapp-api-key_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-demo/navigation/poiapp-api-key_1.0.bb b/recipes-demo/navigation/poiapp-api-key_1.0.bb
new file mode 100644
index 00000000..d353d7dd
--- /dev/null
+++ b/recipes-demo/navigation/poiapp-api-key_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL Reference POI application API key."
+DESCRIPTION = "Preload the API key for the AGL POI application."
+HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION = "apps"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+inherit allarch
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_compile[noexec] = "1"
+
+POIAPP_CLIENT_ID ?= ""
+POIAPP_API_KEY ?= ""
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
+ echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
+}