summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/poiapp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/navigation/poiapp_git.bb')
-rw-r--r--recipes-demo/navigation/poiapp_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-demo/navigation/poiapp_git.bb b/recipes-demo/navigation/poiapp_git.bb
new file mode 100644
index 00000000..2942bf07
--- /dev/null
+++ b/recipes-demo/navigation/poiapp_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL Reference POI application."
+DESCRIPTION = "This application provides the function of destination search to AGL. It uses the API provided by AGL Reference Navigation. This application uses yelp WebAPI."
+HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION = "apps"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
+
+DEPENDS += "qtbase json-c \
+ libhomescreen \
+ libqtappfw \
+ "
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} = "qtbase libqtappfw"