summaryrefslogtreecommitdiffstats
path: root/recipes-demo/waltham-receiver/waltham-receiver_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/waltham-receiver/waltham-receiver_git.bb')
-rw-r--r--recipes-demo/waltham-receiver/waltham-receiver_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo/waltham-receiver/waltham-receiver_git.bb b/recipes-demo/waltham-receiver/waltham-receiver_git.bb
new file mode 100644
index 00000000..d793b066
--- /dev/null
+++ b/recipes-demo/waltham-receiver/waltham-receiver_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Waltham-receiver"
+DESCRIPTION = "Waltham-receiver is a demo application for testing out Waltham"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/waltham-receiver.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "waltham wayland wayland-native \
+ gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
+
+inherit cmake pkgconfig aglwgt
+
+RDEPENDS_${PN} += " \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-plugins-good \
+ gstreamer1.0-plugins-bad \
+ waltham \
+"