summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb50
1 files changed, 36 insertions, 14 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
index 59757819..9ba99faf 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -11,19 +11,45 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
+# MOST out-of-tree kernel drivers
+#################################
+MOST_DRIVERS ??= " \
+ most \
+ "
+# These boards use different kernels - needs to be checked
+MOST_DRIVERS_dra7xx-evm ?= ""
+MOST_DRIVERS_dragonboard-410c ?= ""
+
+
+# HVAC dependencies
+###################
+LIN_DRIVERS ??= " sllin"
+# These boards use different kernels - needs to be checked
+LIN_DRIVERS_dra7xx-evm ?= ""
+LIN_DRIVERS_dragonboard-410c ?= ""
+
+# UNICENS service
+UNICENS ?= " \
+ unicens-config \
+ agl-service-unicens \
+ agl-service-unicens-controller \
+ "
+
+# Hook for demo platform configuration
+# ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
+# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
+DEMO_ENABLE_BTWILINK ?= ""
+DEMO_PLATFORM_CONF = ""
+DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
+
SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
'packagegroup-agl-smartdevicelink', '', d)}"
-# packages from hmi-framework aka homescreen-2017
-HOMESCREEN = "packagegroup-hmi-framework"
-
# removed: now all enablers are in meta-agl-devel/meta-audio-soundmanager-framework
# old audio package
# AUDIO-OLD = "audiomanager"
RDEPENDS_${PN} += "\
- libqtappfw \
- ${HOMESCREEN} \
udisks \
${SMARTDEVICELINK} \
"
@@ -40,23 +66,19 @@ TTF_FONTS = " \
noto-emoji \
"
-#EXTRA_APPS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'qtwebengine', '', d)}"
-#EXTRA_APPS_append = " qtsmarthome cinematicexperience qt5everywheredemo qt5-demo-extrafiles"
-#IMAGE_INSTALL_append = " qtwebengine-examples"
-
-# add support for websocket in Qt and QML
-EXTRA_APPS_append = " qtwebsockets qtwebsockets-qmlplugins"
-PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
-
RDEPENDS_${PN} += " \
linux-firmware-ath9k \
+ linux-firmware-ralink \
can-utils \
iproute2 \
python-curses \
dhcp-client \
+ ${UNICENS} \
+ ${MOST_DRIVERS} \
+ ${LIN_DRIVERS} \
+ ${DEMO_PLATFORM_CONF} \
${TTF_FONTS} \
- ${EXTRA_APPS} \
${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
"