summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2017-12-18 14:20:44 +0000
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2017-12-18 14:37:07 +0000
commit3a467060fecc8eef13295b2f5a12e59343ca6420 (patch)
tree1534a4869507a20de6d9b405ea4ab21040d3defb
parenta8ad9d84d634fc84523feaab352418ad462400ab (diff)
Add XDG Application Launcher on AGL HMI Framework
The launcher of XDG application on AGL HomeScreen/WindowManager. This recipe builds and installs 'runxdg' executable binary into target's /usr/bin. Bug-AGL: SPEC-1096 Change-Id: I6dc7cd025eae0c292238584bf8d8c0036cdb9a60 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb b/meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb
new file mode 100644
index 00000000..629575c5
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/runxdg/runxdg_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Launcher of XDG application on AGL HMI Framework (2017)"
+DESCRIPTION = "The command 'runxdg' is a launcher to execute XDG application \
+ on AGL HMI Framework which using wayland-ivi-extension"
+HOMEPAGE = "https://git.automotivelinux.org/staging/xdg-launcher"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "json-c wayland wayland-ivi-extension virtual/libhomescreen libwindowmanager"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/xdg-launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"